Bug 1025274 - syslinux doesn't have a test suite
syslinux doesn't have a test suite
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: syslinux (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Peter Jones
Release Test Team
:
Depends On:
Blocks: 1024724
  Show dependency treegraph
 
Reported: 2013-10-31 07:05 EDT by Alexander Todorov
Modified: 2013-12-17 08:08 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-17 08:08:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2013-10-31 07:05:20 EDT
Description of problem:

It looks like this package doesn't have an upstream test suite. See
https://fedoraproject.org/wiki/Packaging:Guidelines#Test_Suites


I see nearly 250 bugs across different products/releases for this component. 

QE requests that devel create a test suite or a framework for one so that we can add more tests in the future and provide better test coverage for this component.


Version-Release number of selected component (if applicable):
syslinux-4.05-5.el7.src.rpm
Comment 1 David Cantrell 2013-12-17 08:08:57 EST
We follow upstream on this and hpa hasn't provided a comprehensive test framework.  This should be addressed in Fedora first.

Note You need to log in before you can comment on or make changes to this bug.