Bug 1025283 - system-config-kickstart doesn't have a test suite
system-config-kickstart doesn't have a test suite
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: system-config-kickstart (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
:
Depends On:
Blocks: 1024724
  Show dependency treegraph
 
Reported: 2013-10-31 07:44 EDT by Alexander Todorov
Modified: 2014-08-04 17:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 14:01:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2013-10-31 07:44:09 EDT
Description of problem:


There are nearly 250 bugs against this component and it doesn't have an upstream test suite. Please provide one or at least a base framework for it so that QE can start adding tests.


Version-Release number of selected component (if applicable):
system-config-kickstart-2.9.2-1.el7.src.rpm
Comment 1 David Cantrell 2013-12-17 08:07:41 EST
system-config-kickstart is largely deprecated, so it's unlikely that we will further revise it.  But I'm keeping the bug open for now.
Comment 2 Alexander Todorov 2013-12-18 03:57:25 EST
(In reply to David Cantrell from comment #1)
> system-config-kickstart is largely deprecated, so it's unlikely that we will
> further revise it.  But I'm keeping the bug open for now.

Will it be removed then ? Will there be an alternative package ?
Comment 3 Chris Lumens 2013-12-18 14:01:33 EST
The immediate plan is to reuse anaconda code to provide the UI, since anaconda's just building kickstart files now.  However, I don't see getting around to doing tests for either it or the current UI given how low priority it's been lately.

Note You need to log in before you can comment on or make changes to this bug.