Bug 102533 - unable to add startup programs in KDE
Summary: unable to add startup programs in KDE
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-session (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-16 19:59 UTC by Elton Woo
Modified: 2007-04-18 16:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 12:37:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Elton Woo 2003-08-16 19:59:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
from the Start Here icon on the KDE desktop, the "Sessions" applet
does not load so that one may add a program to startup when logging into
the KDE desktop.

Version-Release number of selected component (if applicable):
kdeutils-3.1.3-3

How reproducible:
Always

Steps to Reproduce:
1.Click on Start Here on the KDE desktop
2.Go to Preferences, then More Preferences
3.Click on "Sessions" 
vfolder:/start-here.menu/Start Here/Preferences/MorePreferences/  

Actual Results:  mouse pointer shows flashing hourglass icon, then disappears.

Expected Results:  the sessions dialog should open for input

Additional info:

Comment 1 Ngo Than 2003-08-18 08:02:32 UTC
it's a bug in gnome-session

Comment 2 Havoc Pennington 2003-08-18 16:08:39 UTC
How is gnome-session involved? Isn't this KDE running?

Comment 3 Elton Woo 2003-08-18 18:22:45 UTC
This is in the KDE desktop. So if it works when the Gnome desktop, why doesn't it
work when I'm in KDE? In effect, I cannot add any startup programs to my KDE
sessions.

Comment 4 Ngo Than 2003-09-16 13:20:46 UTC
Havoc:
the user has tried to start gnome-session-properties in KDE, and it has failed!
i don't know why.

Elton Woo:
It's wrong using gnome-session-properties to add startup programs in KDE.
There's at the moment no such program for KDE. But there is an easier way to add
startup programs in KDE by copying desktop files into $HOME/.kde/Autostart/
You have also to configure session manager before. (kcontrol->KDE
Components->Session Manager)

Comment 5 Elton Woo 2003-09-17 04:46:11 UTC
In that case the "Start Here" folder on the KDE desktop should NOT have a
"sessions" Icon, OR there should be a *separate* "KDE-sessions" icon. 

Since the Start Here folder exists on both desktops and the contents are
_identical_ in either desktop, this is misleading and confusing, since the user
_reasonably expects_ the icons to provide identical fuctionality under either
desktop. There is NO indication that the 
preferences:///MorePreferences --> Sessions icon applies ONLY to the Gnome
destop.

Comment 6 Elton Woo 2003-11-02 21:04:40 UTC
There is a Start Here folder on the KDE desktop, but it is totally
unusable, since it reports "malformed URL" (Fedora Core Test 3. and 
Fedora Core 1),
versions:kdebase-3.1.4-6,kdeartwork-3.1.4-1

Comment 7 Ngo Than 2003-11-05 12:37:36 UTC
Problem is that the the url in starthere.desktop is wrong.
It should be changed to:

 URL=start-here:/

So it will work in both Desktop Enviroment.

or if you remove your $HOME/Desktop directory and restart KDE/GNOME
it should do it for you.

i have fixed gnome-session so that it only shows in Gnome.
gnome-session-2.4.0-2 will include this fix.




Note You need to log in before you can comment on or make changes to this bug.