Bug 1025356 - USBClerk: After installing usbclerk, the client machine can no longer use there usb devices on the client
USBClerk: After installing usbclerk, the client machine can no longer use the...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: usb-clerk-win (Show other bugs)
3.3.0
x86_64 Windows
unspecified Severity medium
: ovirt-3.6.1
: 3.6.1
Assigned To: Uri Lublin
SPICE QE bug list
spice
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 10:26 EDT by Vimal Patel
Modified: 2016-02-10 14:20 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 11:22:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
usbclerk log of install & failure to uninstall the usb driver (898 bytes, text/x-log)
2013-10-31 10:26 EDT, Vimal Patel
no flags Details

  None (edit)
Description Vimal Patel 2013-10-31 10:26:49 EDT
Created attachment 817928 [details]
usbclerk log of install & failure to uninstall the usb driver

Description of problem:
After installing usbclerk, the client machine can no longer use there usb devices on the client.  The usb devices can get redirected to the VMs using remote-viewer; however, the client itself cannot use usb devices on the local system.

I do see an error from spice that states, when deselecting the usb device from remote-viewer:
remote-viewer: <remote-viewer.exe:3656>: GSpice-WARNING **: failed to uninstall win usb driver (status=0)

I also looked into the Event Viewer and I see an error:
Event ID: 7030: The USB Clerk service is marked as an interactive service.  However, the system is configured to not allow interactive services. This service may not function properly.

I looked into this error, and it says as a resolution, go into the service in question(usbclerk), and go to Properties->Log On and select Allow service to interact with desktop.  I selected it; however, the issue still exists.

The client itself sees the mass storage device in Device Manager; however, it doesn't show up on explorer.

A workaround does exist: To get it to show up I need to delete the driver for the mass storage device then it can be seen again, but using remote-viewer will change that again.

I am also attaching the usbclerk.log, which was cleared out and followed the steps mentioned in Steps to Reproduce.

Version-Release number of selected component (if applicable):
mingw-usbclerk-0.0.1.1-3.el6_4
also reproduced w/ usbclerk-win-0.1-11
mingw-virtviewer 0.5.6-6.el6_4

How reproducible:
Hasn't been reproduced on another machine.
I still have the system with the problem and its 100% reproducible on that system.

Steps to Reproduce:
1. I got the client back to an original state where the client can see the usb mass storage device. (stopping usbclerk service, deleting it, and deleting the driver information of the usb storage device from device manager)
2. I installed the usbclerk software.
3. Connected to a VM w/remote-viewer and connected the usb device from the File -> USB Device Selection.
4. disconnected the USB device by deselecting it using the same option (File -> USB Device Selection).
5. shutdown remote-viewer, and then the client no longer sees the usb storage device.

Actual results:
usb devices can only be used by the guest after usbclerk is installed.

Expected results:
usb devices can be used by both client and guest

Additional info:
Comment 1 Uri Lublin 2013-12-08 11:33:02 EST
I can not reproduce it on my setup (with a different USB device).
Possibly a local machine problem, possibly this specific device is problematic.
Needs to be investigated.
Comment 2 Uri Lublin 2013-12-08 11:36:53 EST
The log file shows a successful installation of the WinUSB driver, but a problem with removing the device:

3872::INFO::2013-10-24 09:24:17,754::uninstall_inf::Failed to enumerate driver info: 259
Comment 3 David Blechter 2013-12-08 11:39:03 EST
pushing to 3.4 as we are at RC phase, and based on the latest comment
Comment 4 Sandro Bonazzola 2015-10-26 08:32:39 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 5 Uri Lublin 2015-11-02 11:22:37 EST
(In reply to Sandro Bonazzola from comment #4)
> All bugs not postponed on GA release will be automatically re-targeted to
> 
> - 3.6.1 if severity >= high
> - 4.0 if severity < high

This bug is not high severity and has no customer case.
Since in 4.0 usbclerk is going to be obsolete,
Closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.