Bug 10254 - Man does not work on pages that are symbolic links
Man does not work on pages that are symbolic links
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-19 18:08 EST by mavrin
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-10 02:14:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mavrin 2000-03-19 18:08:12 EST
Man and makewhatis fail for man pages which are symbolic links.  For
example:

   /usr/man/man1/ldapadd.1 is linked to /usr/man/man1/ldapmodify.1

When I do a "man 1 ldapadd" it says the man page does not exist.
Also, I get messages from the weekly cron for makewhatis, here
is a short excerpt:

   Read file error: ./ldapadd.1 No such file or directory
   Read file error: ./cldap.3 No such file or directory
   Read file error: ./ldap_add_s.3 No such file or directory
   Read file error: ./ldap_bind_s.3 No such file or directory
   Read file error: ./ldap_simple_bind.3 No such file or directory
   Read file error: ./ldap_simple_bind_s.3 No such file or directory

I am running RedHat 6.1 on a Packard Bell Platinum 60
Comment 1 mavrin 2000-04-09 14:28:59 EDT
4/9/00 MRH -
I figured out what the problem was on my system.  I had a previous version of
LDAP installed in /usr/local (which I had uninstalled),  so there are symbolic
links hanging out in /usr/local/man that were orphans.

Don't know if you still want to call this a bug or not.  You could change the
code to keep searching the MANPATH until it finds a readable file.
Comment 2 Graham Stoney 2000-05-10 02:14:59 EDT
We've also encountered the same problem: man stops searching when it encounters
a dangling symlink. I'd like to add my "it's a bug, please fix" vote.
Comment 3 Bernhard Rosenkraenzer 2000-10-12 10:07:59 EDT
Fixed in 1.5h1-13

Note You need to log in before you can comment on or make changes to this bug.