Bug 1025426 - [RHEVM-ENGINE] Only some vms are migrating when their host moved to maintenance
[RHEVM-ENGINE] Only some vms are migrating when their host moved to maintenance
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: nobody nobody
virt
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 12:30 EDT by Barak Dagan
Modified: 2014-07-13 19:19 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 08:19:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine + 2 vdsms log (755.95 KB, application/x-tar-gz)
2013-10-31 12:30 EDT, Barak Dagan
no flags Details

  None (edit)
Description Barak Dagan 2013-10-31 12:30:50 EDT
Created attachment 817981 [details]
engine + 2 vdsms log

Description of problem:
5 VMs are running on src host.
The hosts is moved to maintenance, triggering migration to 2nd host.
Host is stuck in waiting for maintenance state, since 2 VMs are nor migrating.

These VMs migrated manually, releasing host to maintenance work.

Version-Release number of selected component (if applicable):
is21

How reproducible:
100%

Steps to Reproduce:
1. NFS DC with 1 host.
2. 5 VMs running on 1st host (SPM)
3. Adding 2 host.
4. Moving SPM to Maintenance.

Actual results:
2 VMs didn't migrate

Expected results:
All VMs migrating

Additional info:
Comment 2 Michal Skrivanek 2013-11-07 08:57:57 EST
I see the machines(I checked 2 which are in the logs - there's nothing else there) migrated, however the logs are cluttered with errors which seem to be related to vdsm hooks which are in place. Please try without them and/or please narrow the time period
Comment 3 Barak Dagan 2013-11-13 08:19:00 EST
IS22, can't reproduce.

Note You need to log in before you can comment on or make changes to this bug.