Bug 1025432 - Screen is not locked even when Power button action set to hibernate
Screen is not locked even when Power button action set to hibernate
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cinnamon-screensaver (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 12:48 EDT by Andrew Duggan
Modified: 2013-10-31 13:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 13:33:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Duggan 2013-10-31 12:48:53 EDT
Description of problem:

In Cinnamon 2.0.3  the screen is not locked if one chooses hibernate for the power button action regardless of the lock screen setting on wake.

I have in the power control panel "Power button action" = hibernate 
and 
In the screensaver and Lock Settings, I have "Require my password when waking from suspend" set to on, as confirmed by the gsettings below

gsettings get org.cinnamon.settings-daemon.plugins.power button-power
'hibernate'
gsettings get org.cinnamon.settings-daemon.plugins.power lock-on-suspend
true


Version-Release number of selected component (if applicable):
cinnamon-settings-daemon-2.0.3-1.fc19.i686


How reproducible:
Always


Steps to Reproduce:
1. Correctly Configure Power and lock settings as described above
2. Press Power
3.

Actual results:

System hibernates, but the screen is not locked on resume.

Expected results:

System hibernates, and the screen is locked on resume


Additional info:

/etc/systemd/logind.conf 

HandlePowerKey=ignore

which is necesssary to allow cinnamon-settings-daemon to have control over what the power button does at all.

If the gsettings get org.cinnamon.settings-daemon.plugins.power button-power
is set to interactive, and I get a the dialog box asking to Hibernate, or suspended, or poweroff or logout, and I select Hibernate, the system, does lock the screen as expected.  

Cinnamon on Fedora 17 which still used the gnome-settings, did the right thing. So it seems to be a 2.0.x problem
Comment 2 Andrew Duggan 2013-10-31 13:33:29 EDT
Brilliant!  Thanks.  Fastest Resolution ever.  Works exactly right.

Note You need to log in before you can comment on or make changes to this bug.