Bug 1025459 - hwcert-server error downloading attached python files.
hwcert-server error downloading attached python files.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.7.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks: 1016295 1040734
  Show dependency treegraph
 
Reported: 2013-10-31 14:30 EDT by Greg Nichols
Modified: 2016-07-05 13:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: hwcert-client 1.7.0-20131119.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1040734 1069903 (view as bug list)
Environment:
Last Closed: 2016-07-05 13:51:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2013-10-31 14:30:34 EDT
Description of problem:

When trying to download python file attachments via the "Attachments" link, the download files because the server can figureout the mime type for ".py", and 
gives the message:

Error: could not find content type from file name: u'py'

Version-Release number of selected component (if applicable):

hwcert-server 1.7.0-62

Steps to Reproduce:
1. do a trival edit on a python file in hwcert-client's source,
such as /usr/share/hwcert/tests/usb/usb.py
2. run "hwcert-backend --test info" (the info test will fail validation of the sources, and attache the usb.py file
3. hwcert-backend save --server <server host>
4. view the results on the <server host>, click the "Attachments" link, then click the "usb.py" link.
Comment 4 Brian Brock 2014-02-12 13:37:04 EST
verified in 20140210

Note You need to log in before you can comment on or make changes to this bug.