Bug 1025466 - Plugin pack for DV6 (EDS6) must be renamed from "EDS" to "DV"
Plugin pack for DV6 (EDS6) must be renamed from "EDS" to "DV"
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: JON (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: GA
: 6.0
Assigned To: Dave Stahl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 14:42 EDT by Len DiMaggio
Modified: 2015-11-08 20:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-10 14:38:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDRHQ-18 Major Resolved Change "data services" to "data virtualization" 2015-06-02 11:23:49 EDT

  None (edit)
Description Len DiMaggio 2013-10-31 14:42:07 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Len DiMaggio 2013-10-31 14:46:06 EDT
See:   https://issues.jboss.org/browse/TEIIDRHQ-18
Comment 2 Van Halbert 2013-10-31 14:56:38 EDT
Completed the changes to teiid-rhq plugin, for renaming data services to data virtualization.

Assigning to David to handle the product renaming in the build.
Comment 4 Simeon Pinder 2013-11-01 17:14:05 EDT
Hi Van/Filip,
  Can one of you clarify this request as soon as possible? Thx.
----- Original Message -----
> From: "Simeon Pinder" <spinder@redhat.com>
> To: "Van Halbert" <vhalbert@redhat.com>
> Cc: "Filip Nguyen" <fnguyen@redhat.com>, "Leonard Dimaggio" <ldimaggi@redhat.com>, "David Stahl" <dstahl@redhat.com>
> Sent: Friday, November 1, 2013 5:07:52 PM
> Subject: Re: DV Plugin Pack rebuild request
> 
> Hi Van and Filip,
> 
>   So there's a little confusion here. A few things to clarify before I can
>   act on this:
> 
> i)The 'plugin pack' represents the most up to date management functionality
> for your product, which typically includes multiple 'plugins' and versions.
> Ex. EDS plugin pack includes all related EDS plugins() and the associated
> dependencies.  Additionally one can have one's plugin pack name changed
> without changing any of the underlying plugins(eds-p*,teid*,soa-p*) or
> versions. See following for ER4 plugin pack
> name(http://download.devel.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.2.0.ER4/2/maven/org/jboss/on/jon-plugin-pack-dataservices/3.2.0.ER4/jon-plugin-pack-dataservices-3.2.0.ER4.zip),
> and look into the same for the plugin pack contents and all of it's
> associated management dependencies.
> 
> ii)Any change to the plugin pack, name or payload requires a plugin pack
> request.  Multiple changes can be included in a single request/BZ.
> 
> iii)All plugin pack update requests typically follow the process described
> here: https://docspace.corp.redhat.com/docs/DOC-124228
> 
> With that being said, it looks like you want:
> 1)plugin pack rename from 'DATASERVICES' -> DV.  Is this correct? Title from
> [1] implies as much. This is the least clear of all your current requests.
> 2)You'd like the EDS/Dataservice plugin pack depdendency for teeid-rhq-plugin
> version updated to '1.0.0.Final-redhat-4' from
> '1.0.0.Final-redhat-2'(current version requested by [2]).
> https://bugzilla.redhat.com/show_bug.cgi?id=1025466#c3 implies that this
> should now be the latest.
> 3)[1] should be assigned to me as the JON team is still responsible for the
> formalized plugin pack builds.  Assuming you want that BZ to track the
> plugin pack change request.
> 
> Since you've already created [1], it is fine to make the modifications if the
> above is correct. Please advise if I have interpreted the requested changes
> correctly.
> 
> -Simeon
> 
> ----- Original Message -----
> > From: "Van Halbert" <vhalbert@redhat.com>
> > To: "Filip Nguyen" <fnguyen@redhat.com>
> > Cc: "Simeon Pinder" <spinder@redhat.com>, "Leonard Dimaggio"
> > <ldimaggi@redhat.com>, "David Stahl" <dstahl@redhat.com>
> > Sent: Friday, November 1, 2013 10:08:00 AM
> > Subject: Re: DV Plugin Pack rebuild request
> > 
> > Including David on this.  I believe he pulled the new code and was kicking
> > off a build (IIRC).
> > 
> > Van
> > 
> > ----- Original Message -----
> > From: "Filip Nguyen" <fnguyen@redhat.com>
> > To: "Simeon Pinder" <spinder@redhat.com>
> > Cc: "Van Halbert" <vhalbert@redhat.com>, "Leonard Dimaggio"
> > <ldimaggi@redhat.com>
> > Sent: Friday, November 1, 2013 8:47:13 AM
> > Subject: DV Plugin Pack rebuild request
> > 
> > Hi Simeon,
> > I wanted to ask about the process of rebuilding the plugin pack for DV
> > 6. Since Van finished the changes [1] in our plugin pack (reflecting
> > product name change) should we request the rebuild again or is this [2]
> > sufficient?
> > 
> > [1] https://bugzilla.redhat.com/show_bug.cgi?id=1025466
> > <https://bugzilla.redhat.com/show_bug.cgi?id=1025466>
> > [2] https://bugzilla.redhat.com/show_bug.cgi?id=1010365
> > <https://bugzilla.redhat.com/show_bug.cgi?id=1010365>
Comment 5 Filip Nguyen 2013-11-04 13:29:49 EST
We need to propagate a change of the product (former Data Services) to Data Virtualization, that would mean:

* plugin pack name change ("jon-plugin-pack-dataservices-" -> "jon-plugin-pack-datavirtualization-")

* plugins name changes ("eds-p-" -> "dv-")

Code changes for ModeShape and Teiid plugins has been pushed to  jboss-integration git repo. So these changes also need to be propagated integrated.
Comment 6 Simeon Pinder 2013-11-07 11:25:29 EST
I have made the requested changes which are available to test in the latest brew build: https://brewweb.devel.redhat.com//buildinfo?buildID=306513 (JON 3.2.0.ER5)

More specifically:
- the plugin pack was renamed from dataservices -> datavirtualization
- teeid-rhq-plugin version updated to '1.0.0.Final-redhat-4' from '1.0.0.Final-redhat-2'
- no eds-p plugin name changes were made at this time since the specific "eds-p" plugin pack dependencies were all for existing/legacy plugins (eds-p-5.3.0.GA-*plugin.jar) and there were no other specific dependency changes mentioned in any of the associated BZ's.

@Filip and @Van, please have your team test/verify and report any issues with these changes.  I will consider this request complete unless indicated otherwise.
Comment 7 JBoss JIRA Server 2013-11-07 11:38:10 EST
Van Halbert <vhalbert@jboss.org> made a comment on jira TEIIDRHQ-18

1 issue, the modeshape-rhq plugin isn't in the zip.      Not sure who should be pulling the jboss-integration/modeshape-rhq into the build.
Comment 8 Simeon Pinder 2013-11-07 11:50:15 EST
@Van, thanks for catching that. Can you get me or have someone:
i) get me the brew library links for the 'modeshape-rhq plugin'
ii)confirm that that plugin[i] needs to be added as a dependency for the datavirtualization plugin pack for JON 3.2.0.GA? 

I'll get started on pulling those changes in for JON 3.2.0.ER6 which I'm going to start working on as early as tomorrow. 

Thx.
Comment 9 JBoss JIRA Server 2013-11-08 14:13:37 EST
Van Halbert <vhalbert@jboss.org> made a comment on jira TEIIDRHQ-18

Modeshape rhq plugin should be included the same way the Teiid rhq plugin is included.
Comment 11 Simeon Pinder 2013-11-18 19:26:28 EST
This is fixed with commit ada950dabad5e6e to jon.git. Moving this to MODIFIED for testing with next brew build.
Comment 12 Simeon Pinder 2013-11-22 10:04:28 EST
ER6 was found to be a bad build, but ER7 is valid and includes this fix as well. 

@Van and @Dave, this is available for verification.

Cancelling original needinfo.
Comment 13 belong 2013-12-01 22:48:12 EST
Assuming we don't need to document this as an issue in Release Notes - setting to requires_doc_text- accordingly.

Note You need to log in before you can comment on or make changes to this bug.