Bug 1025472 - Nvidia GPU device assignment - qemu-kvm - bus reset support
Nvidia GPU device assignment - qemu-kvm - bus reset support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Williamson
Virtualization Bugs
:
Depends On: 1025468
Blocks: 1291981 987658 1032793 1032795
  Show dependency treegraph
 
Reported: 2013-10-31 14:59 EDT by Alex Williamson
Modified: 2016-07-28 03:14 EDT (History)
7 users (show)

See Also:
Fixed In Version: qemu-kvm-1.5.3-17.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:17:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Williamson 2013-10-31 14:59:08 EDT
Description of problem:
In order to support devices like Nvidia Quadro which presents itself as a multifunction device PCI device (GPU + HDA) with no function level reset mechanisms we need to support co-assigned bus reset.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Miroslav Rezanina 2013-11-07 10:56:41 EST
Fix included in qemu-kvm-1.5.3-17.el7
Comment 5 juzhang 2014-03-03 01:24:02 EST
Please notes:

1.QE does not test Telsa card since we do not get this card from Nvidia.
2. "NVIDIA GPU Device Assignment Red Hat Enterprise Linux 7.0 Beta supports device assignment of NVIDIA professional series graphics devices (GRID and 
Quadro) as a secondary graphics device to emulated VGA.",According to last comment in bz987658's Doc Text, Telsa is not mentioned. 
3. QE will consider test telas card as well if we get the card from nvidia timely(before snapshot10). Free to update your comment as well.
Comment 7 Ludek Smid 2014-06-13 09:17:26 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.