Bug 1025544 - Hammer CLI: Many organization and architecture "add_*" sub-commands fail with error
Hammer CLI: Many organization and architecture "add_*" sub-commands fail wit...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tomas Strachota
Tazim Kolhar
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1027170
  Show dependency treegraph
 
Reported: 2013-10-31 17:00 EDT by Apurva Bhole
Modified: 2016-04-25 20:58 EDT (History)
6 users (show)

See Also:
Fixed In Version: rubygem-foreman_api-0.1.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:07:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 3555 None None None 2016-04-22 12:56 EDT

  None (edit)
Description Apurva Bhole 2013-10-31 17:00:35 EDT
Description of problem:
Even on using valid name/id parameters, hammer organization sub-commands:
add_environment, add_domain, add_subnet, add_user and more. 
Also hammer architecture add_operatingsystem always fail.

Version-Release number of selected component (if applicable):
rubygem-hammer_cli_foreman-0.0.9-2.el6sat.noarch
rubygem-hammer_cli-0.0.8-2.el6sat.noarch

rubygem-foreman_api-0.1.7-3.el6sat.noarch
katello-foreman-all-1.4.6-55.el6sat.noarch
artemis.usersys.redhat.com-foreman-client-1.0-1.noarch
foreman-postgresql-1.3.0-24.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-4.el6sat.noarch
artemis.usersys.redhat.com-foreman-proxy-1.0-1.noarch
rubygem-hammer_cli_foreman-0.0.9-2.el6sat.noarch
foreman-1.3.0-24.el6sat.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-7.el6sat.noarch
katello-configure-foreman-1.4.7-7.el6sat.noarch
ruby193-rubygem-foreman_api-0.1.7-2.el6sat.noarch
foreman-proxy-1.3.0-3.el6sat.noarch


How reproducible:
always

Steps to Reproduce:
1. organization create --name org1
2. environment create --name envOne
3. organization add_environment --name org1 --environment-id 3
4. organization add_environment --name org1 --environment envOne

Actual results:
Error: resource or action not defined

Expected results:
It should be executed successfully
Comment 1 RHEL Product and Program Management 2013-10-31 17:05:24 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Dominic Cleal 2013-11-22 07:22:53 EST
Should be fixed in:
  hammer_cli 0.0.9
  hammer_cli_foreman 0.0.10
  foreman_api 0.1.8
Comment 5 Garik Khachikyan 2014-01-14 08:35:37 EST
qA_ack+ to this.
Comment 9 Tazim Kolhar 2014-05-09 09:00:44 EDT
VERIFIED

# hammer organization add-environment --name org1 --environment envOne
Comment 10 Bryan Kearney 2014-07-02 10:07:57 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.