Bug 1025564 - Requiring pass phrase to reformat is pointless and obstructive
Requiring pass phrase to reformat is pointless and obstructive
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 18:23 EDT by feddy
Modified: 2013-11-01 17:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-01 14:07:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description feddy 2013-10-31 18:23:03 EDT
Description of problem:

during installation configuration, if an encypted partition is selected anaconda refuses to do anything with it until the correct pass phrase is supplied. 

This is totally pointless. Just about any linux live CD could be used to reformat it in two seconds. All this "feature" does is obliges user to quit Fedora, scrub that partition and start again. 

Encryption is to protect data from being read. It cannot prevent it from being erased, so don't try. 

PITA sure, but not anything that will protect the partition. 

What if the pass phrase is forgotten ? Is the disk to remain unusuable for ever?
This is very muddles thinking. 



Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Create Fed installation with an encrypted partition
2. re-run installer
3. select encrypted partn. : asked for pass phrase.


Actual results:
anaconda does not display the usual configuration inputs until the pass phrase has been supplied. 

Expected results:
Abililty to reformat to a clean partition without supplying pass phrase. 

Additional info:
Comment 1 David Shea 2013-11-01 10:32:56 EDT
You don't need a passphrase to remove the partition. Just select the LUKS partition and hit "remove", just like any other partition.
Comment 2 feddy 2013-11-01 14:05:16 EDT
Why would I logically think of removing it only in order to add it again. 

I do not want to remove it , I wish to reformat it as a non encrypted partition. That should be possible directly from the options offered and asking for the pass-phrase is illogical and pointless as in the report. 

What you have described is a work around. The bug exists as reported.
Comment 3 David Shea 2013-11-01 14:07:18 EDT
You'd remove it because it's encrypted and we can't read it if you don't provide a passphrase. There's no such as thing as "reformatting" an LUKS partition. Either you enter the passphrase so you can examine and manipulate the contents, or you throw it out.
Comment 4 feddy 2013-11-01 17:30:09 EDT
"Either you enter the passphrase so you can examine and manipulate the contents, or you throw it out."

It does not matter what you want to call it. There is a check box for reformat, and even if I want to "throw it out" by reformatting as straight ext4 for "throw it out" and make a new luks, it boils down to the same thing. Asking for the pass phrase to "throw it out" is dumb. That's currently what Fedora does. 

Removing it only to add back in remains a work around. 

I took the time to report the bug , I don't have time to play games. If you want to keep the pointless buggy requirement for pass phrase and force used to guess your workaround or reboot a different OS/disto in order to remove it... well keep your bug and call it NOTABUG.

That makes me 10x less likely to file a bug report next time I find one.

Note You need to log in before you can comment on or make changes to this bug.