Bug 1025570 - Packstack uses quantum-named directories in rootwrap.conf
Packstack uses quantum-named directories in rootwrap.conf
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
4.0
Unspecified Unspecified
low Severity low
: z2
: 4.0
Assigned To: Jakub Libosvar
Ofer Blaut
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 18:47 EDT by Summer Long
Modified: 2016-04-26 16:15 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-neutron-2013.2.1-6.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-04 15:13:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Summer Long 2013-10-31 18:47:22 EDT
Description of problem:
Old quantum directories are used in rootwrap.conf

Version-Release number of selected component (if applicable):
2013.2.1-0.11.dev806.el6

How reproducible:
vi /etc/neutron/rootwrap.conf

Actual results:
The following is written in rootwrap.conf:

[DEFAULT]
# List of directories to load filter definitions from (separated by ',').
# These directories MUST all be only writeable by root !
filters_path=/etc/neutron/rootwrap.d,/usr/share/neutron/rootwrap,/etc/quantum/rootwrap.d,/usr/share/quantum/rootwrap

Expected results:
Should use /etc/neutron and /usr/share/neutron directories

Additional info:
Comment 2 Alvaro Lopez Ortega 2013-12-03 13:00:18 EST
The first entries are correct for Neutron, the rest are a safety net for older Quantum deployments.  Martin to check it out.
Comment 3 Martin Magr 2013-12-03 13:25:46 EST
Aren't those quantum folders as fallback for quantum->neutron migration?
Comment 4 Jakub Libosvar 2013-12-03 14:18:29 EST
(In reply to Martin Magr from comment #3)
> Aren't those quantum folders as fallback for quantum->neutron migration?

Indeed. These paths are there intentionally.
Comment 5 Summer Long 2013-12-03 17:50:40 EST
Thanks for that, Jakub. Perhaps a comment in the file would make it clear to the user? cheers, Summer
Comment 6 Alvaro Lopez Ortega 2014-01-07 12:30:51 EST
Reassigning to the Neutron team for their evaluation. Whether or not to put that comment in the configuration file will be their call.
Comment 10 Ofer Blaut 2014-02-18 08:45:57 EST
New comment was added


DEFAULT]
# List of directories to load filter definitions from (separated by ',').
# These directories MUST all be only writeable by root !
# Paths contain quantum due to backward compatibility with quantum rootwrap commands
filters_path=/etc/neutron/rootwrap.d,/usr/share/neutron/rootwrap,/etc/quantum/rootwrap.d,/usr/share/quantum/rootwrap

openstack-packstack-2013.2.1-0.24.dev982.el6ost.noarch
Comment 12 errata-xmlrpc 2014-03-04 15:13:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0213.html

Note You need to log in before you can comment on or make changes to this bug.