Bug 1025728 - Artificial line wrapping of bugs wastes browser real estate
Artificial line wrapping of bugs wastes browser real estate
Status: CLOSED DUPLICATE of bug 965911
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
4.4
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 07:50 EDT by Daniel Berrange
Modified: 2013-11-26 00:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 00:30:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Broken formatting caused by BZ CSS constraining comment width (254.63 KB, image/jpeg)
2013-11-01 07:51 EDT, Daniel Berrange
no flags Details
Good formatting when CSS is disabled, allowing comment to fill browser window width (354.22 KB, image/jpeg)
2013-11-01 07:52 EDT, Daniel Berrange
no flags Details

  None (edit)
Description Daniel Berrange 2013-11-01 07:50:10 EDT
Description of problem:
In many of the bugs I have to deal with, people paste in log messages and other  blocks of pre-formatted text. Unfortunately the bugzilla CSS is causing the text to line wrapped at 600px, by using a constrained dimension for comment text blocks. My browser window meanwhile is 1980px wide, and has plenty of space to view the text from bugs without artificial line wrapping.

This rather harms the usability of bugzilla viewing comments

If I wanted text wrapped at 600px, then I could keep my browser window at such small sizes. I intentionally have a large browser window so I can see line longs without artifical wrapping, but bugzilla CSS prevents that.

This doesn't seem to be Red Hat specific - switching to the 'Classic' CSS style, I see the same thing. So I think Red Hat CSS would need to override whatever upstream CSS rule does this fixed width.


Version-Release number of selected component (if applicable):
4.4.0009

How reproducible:
Always

Steps to Reproduce:
1. Open https://bugzilla.redhat.com/show_bug.cgi?id=1005570
2. Look at text in comment #3
3.

Actual results:
CSS causes log lines to be line wrapped, totally mangling the comment, making it unreadable.

Expected results:
Comment is allowed to fill entire browser window horizontal real estate. 

Additional info:
Comment 1 Daniel Berrange 2013-11-01 07:51:28 EDT
Created attachment 818260 [details]
Broken formatting caused by BZ CSS constraining comment width
Comment 2 Daniel Berrange 2013-11-01 07:52:07 EDT
Created attachment 818261 [details]
Good formatting when CSS is disabled, allowing comment to fill browser window width
Comment 3 Simon Green 2013-11-26 00:30:55 EST
Comments are wrapped by default. You can change the default behaviour by changing the "Wrap comments by default" value in your preference, or temporary by clicking the 'Unwrap comments' link to the right of the topmost[1] comment.

When doing this, comment 3 expands as wide as my browser allows (except for the space required to show the links on the right of the top most comment)

  -- simon


[1] This is the bug description by default, unless you sort your comments as newest first.

*** This bug has been marked as a duplicate of bug 965911 ***

Note You need to log in before you can comment on or make changes to this bug.