Bug 1025768 - The 'rhc apps' fail after unsuccessful downloadable cartridge install
The 'rhc apps' fail after unsuccessful downloadable cartridge install
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 10:04 EDT by Michal Fojtik
Modified: 2015-05-14 20:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:28:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Fojtik 2013-11-01 10:04:19 EDT
Description of problem:

After I tried to add my own downloadable cartridge to an ruby-1.9 application, the application become unavailable and the 'rhc apps' command seems to be broken.

The cartridge I tried to add had an typo in install script (I forgot to source the BASH SDK), so the install script failed. How the application seems to have the cartridge assigned, even if the cartridge does not exists.


Version-Release number of selected component (if applicable):

devenv

How reproducible:

Create an empty ruby-1.9 app and then add a broken downloadable cartridge to it.
If the install script in this downloadable cart fail, the 'rhc apps' prints this error:

~/ruby02 → rhc apps
Unable to complete the requested operation due to: The application 'ruby02' requires
'mfojtik-haproxystats-0.1' but a matching cartridge could not be found.

Steps to Reproduce:

1. $ rhc app create ruby02 -s ruby-1.9
2. $ rhc add-cartridge http://cartreflect-claytondev.rhcloud.com/reflect?github=mfojtik/openshift-origin-cartridge-haproxystats
3. $ rhc apps

Actual results:

Unable to complete the requested operation due to: The application 'ruby02' requires
'mfojtik-haproxystats-0.1' but a matching cartridge could not be found.

Expected results:

When the install script fail, the cartridge should not be registered to an app.

Additional info:
Comment 1 Abhishek Gupta 2013-11-13 14:40:17 EST
This is now fixed.
Comment 2 Jianwei Hou 2013-11-13 21:26:45 EST
Verified on devenv_4030, after install failure, the cartridge is not registered to the application.

Note You need to log in before you can comment on or make changes to this bug.