Bug 1025769 - [abrt] WARNING: CPU: 2 PID: 283 at drivers/net/wireless/iwlwifi/dvm/tx.c:456 iwlagn_tx_skb+0xc10/0xca0 [iwldvm]()
[abrt] WARNING: CPU: 2 PID: 283 at drivers/net/wireless/iwlwifi/dvm/tx.c:456 ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fedora-kernel-wireless-iwl
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:c727b569cf29a0ce693e9f23be3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 10:05 EDT by Paulo Fidalgo
Modified: 2013-11-12 21:13 EST (History)
8 users (show)

See Also:
Fixed In Version: kernel-3.11.7-100.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 23:39:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (79.87 KB, text/plain)
2013-11-01 10:05 EDT, Paulo Fidalgo
no flags Details

  None (edit)
Description Paulo Fidalgo 2013-11-01 10:05:43 EDT
Additional info:
reporter:       libreport-2.1.9
WARNING: CPU: 2 PID: 283 at drivers/net/wireless/iwlwifi/dvm/tx.c:456 iwlagn_tx_skb+0xc10/0xca0 [iwldvm]()
Modules linked in: nf_nat_h323 nf_conntrack_h323 nf_nat_pptp nf_nat_proto_gre nf_conntrack_pptp nf_conntrack_proto_gre nf_nat_tftp nf_conntrack_tftp nf_nat_sip nf_conntrack_sip nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp xt_CHECKSUM tun nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE rfcomm ip6t_REJECT xt_conntrack bnep ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw dm_crypt uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media arc4 iwldvm mac80211 btusb bluetooth iTCO_wdt
 iTCO_vendor_support x86_pkg_temp_thermal coretemp kvm_intel kvm crc32_pclmul crc32c_intel ghash_clmulni_intel sdhci_pci sdhci mmc_core e1000e lpc_ich ptp mfd_core pps_core snd_hda_codec_hdmi microcode snd_hda_codec_realtek iwlwifi snd_hda_intel snd_hda_codec joydev serio_raw snd_hwdep cfg80211 snd_seq snd_seq_device toshiba_acpi sparse_keymap rfkill snd_pcm wmi toshiba_bluetooth snd_page_alloc mei_me snd_timer snd mei soundcore shpchp tpm_tis tpm_infineon tpm tpm_bios video mperf uinput binfmt_misc radeon i2c_algo_bit drm_kms_helper ttm drm i2c_core
CPU: 2 PID: 283 Comm: irq/51-iwlwifi Not tainted 3.11.6-200.fc19.x86_64 #1
Hardware name: TOSHIBA TECRA R840/Portable PC, BIOS Version 4.10   01/08/2013
 0000000000000009 ffff880230fd5738 ffffffff81647c7f 0000000000000000
 ffff880230fd5770 ffffffff8106715d ffff88022f941200 ffff88020b8dbb00
 ffff880230fc1770 0000000000000008 0000000000000000 ffff880230fd5780
Call Trace:
 [<ffffffff81647c7f>] dump_stack+0x45/0x56
 [<ffffffff8106715d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8106723a>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa0547170>] iwlagn_tx_skb+0xc10/0xca0 [iwldvm]
 [<ffffffffa0600f79>] ? ieee80211_crypto_tkip_encrypt+0x149/0x1e0 [mac80211]
 [<ffffffffa0544212>] iwlagn_mac_tx+0x22/0x40 [iwldvm]
 [<ffffffffa061b125>] __ieee80211_tx+0x125/0x350 [mac80211]
 [<ffffffffa061d3df>] ieee80211_tx+0xbf/0xf0 [mac80211]
 [<ffffffffa061d5fd>] ieee80211_xmit+0x9d/0x100 [mac80211]
 [<ffffffffa061e53d>] ieee80211_subif_start_xmit+0xbad/0xd00 [mac80211]
 [<ffffffff81583160>] ? ip_local_deliver_finish+0xd0/0x210
 [<ffffffff8154d608>] dev_hard_start_xmit+0x318/0x560
 [<ffffffff8156b3b0>] sch_direct_xmit+0xe0/0x1c0
 [<ffffffff8154da49>] dev_queue_xmit+0x1f9/0x480
 [<ffffffffa0616cf3>] ieee80211_deliver_skb.isra.27+0xd3/0x210 [mac80211]
 [<ffffffffa0618165>] ieee80211_rx_handlers+0xc35/0x2130 [mac80211]
 [<ffffffff810957bc>] ? resched_task+0x5c/0x60
 [<ffffffff810a2000>] ? update_sd_lb_stats+0x110/0x5a0
 [<ffffffffa0619ad8>] ieee80211_prepare_and_rx_handle+0x478/0xab0 [mac80211]
 [<ffffffff81191488>] ? __kmalloc_node_track_caller+0x78/0x2c0
 [<ffffffffa061a3fd>] ieee80211_rx+0x2ed/0x850 [mac80211]
 [<ffffffff8153c5a1>] ? __kmalloc_reserve.isra.26+0x31/0x90
 [<ffffffffa055105d>] iwlagn_rx_reply_rx+0x3cd/0x710 [iwldvm]
 [<ffffffffa055228e>] iwl_rx_dispatch+0x8e/0xf0 [iwldvm]
 [<ffffffffa036b0aa>] iwl_pcie_irq_handler+0x84a/0xcb0 [iwlwifi]
 [<ffffffff810f6c20>] ? irq_finalize_oneshot.part.29+0xe0/0xe0
 [<ffffffff810f6c40>] irq_thread_fn+0x20/0x50
 [<ffffffff810f6c20>] ? irq_finalize_oneshot.part.29+0xe0/0xe0
 [<ffffffff810f6f2f>] irq_thread+0x11f/0x150
 [<ffffffff810f6cc0>] ? irq_forced_thread_fn+0x50/0x50
 [<ffffffff810f6e10>] ? irq_thread_check_affinity+0x90/0x90
 [<ffffffff81088650>] kthread+0xc0/0xd0
 [<ffffffff81088590>] ? insert_kthread_work+0x40/0x40
 [<ffffffff81656dec>] ret_from_fork+0x7c/0xb0
 [<ffffffff81088590>] ? insert_kthread_work+0x40/0x40
Comment 1 Paulo Fidalgo 2013-11-01 10:05:56 EDT
Created attachment 818295 [details]
File: dmesg
Comment 2 Clayton Fyffe 2013-11-02 23:25:49 EDT
Description of problem:
All I know is that starting about 3 seconds before this error occurs, my wireless card stops working until about 5 minutes later. It mostly occurs after 2+ weeks uptime with more than 50 GiB of data being transfered a day. Most of the time, ABRT won't allow me to report it.

Hardware:
CPU: Intel Core i5 3337U
GPU: Intel HD Graphics 4000
RAM: 6 GiB (2+4, 1600 MHz DDR3), brands unknown
WLAN: Intel Centrino Wireless-N 2230

If it helps, it's  a Dell Inspiron 5521

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.9
cmdline:        BOOT_IMAGE=/vmlinuz-3.11.6-200.fc19.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 vconsole.keymap=us rd.luks=0 vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora/root rhgb quiet LANG=en_US.UTF-8
kernel:         3.11.6-200.fc19.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 1 PID: 1159 at drivers/net/wireless/iwlwifi/dvm/tx.c:456 iwlagn_tx_skb+0xc10/0xca0 [iwldvm]()
Modules linked in: nf_nat_h323 nf_conntrack_h323 nf_nat_pptp nf_nat_proto_gre nf_conntrack_pptp nf_conntrack_proto_gre nf_nat_tftp nf_conntrack_tftp nf_nat_sip nf_conntrack_sip nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp fuse nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6t_REJECT xt_conntrack rfcomm bnep ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw vfat fat x86_pkg_temp_thermal uvcvideo snd_hda_codec_hdmi arc4 iwldvm mac80211 videobuf2_vmalloc videobuf2_memops videobuf2_core videodev iTCO_wdt
 iTCO_vendor_support dell_wmi sparse_keymap coretemp kvm_intel snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq dell_laptop dcdbas snd_seq_device iwlwifi btusb cfg80211 media kvm snd_pcm snd_page_alloc snd_timer snd r8169 joydev mii shpchp soundcore bluetooth rfkill wmi crc32_pclmul crc32c_intel ghash_clmulni_intel lpc_ich mfd_core mei_me mei serio_raw microcode i2c_i801 uinput mperf i915 i2c_algo_bit drm_kms_helper drm i2c_core video
CPU: 1 PID: 1159 Comm: wpa_supplicant Not tainted 3.11.6-200.fc19.x86_64 #1
Hardware name: Dell Inc. Inspiron 5521/0K08H3, BIOS A09 06/25/2013
 0000000000000009 ffff8801b0b8f6a0 ffffffff81647c7f 0000000000000000
 ffff8801b0b8f6d8 ffffffff8106715d ffff8801990fbc80 ffff88019cec4b00
 ffff8801bf611770 0000000000000008 0000000000000000 ffff8801b0b8f6e8
Call Trace:
 [<ffffffff81647c7f>] dump_stack+0x45/0x56
 [<ffffffff8106715d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8106723a>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa0510170>] iwlagn_tx_skb+0xc10/0xca0 [iwldvm]
 [<ffffffffa050d212>] iwlagn_mac_tx+0x22/0x40 [iwldvm]
 [<ffffffffa0473125>] __ieee80211_tx+0x125/0x350 [mac80211]
 [<ffffffffa04753df>] ieee80211_tx+0xbf/0xf0 [mac80211]
 [<ffffffffa04755fd>] ieee80211_xmit+0x9d/0x100 [mac80211]
 [<ffffffffa0476970>] __ieee80211_tx_skb_tid_band+0x70/0x80 [mac80211]
 [<ffffffffa046bb99>] ieee80211_mgmt_tx+0x349/0x380 [mac80211]
 [<ffffffff81046363>] ? x2apic_send_IPI_mask+0x13/0x20
 [<ffffffffa02d4740>] cfg80211_mlme_mgmt_tx+0x130/0x370 [cfg80211]
 [<ffffffffa02c3217>] nl80211_tx_mgmt+0x277/0x350 [cfg80211]
 [<ffffffff81579a5c>] genl_family_rcv_msg+0x17c/0x380
 [<ffffffff81579c60>] ? genl_family_rcv_msg+0x380/0x380
 [<ffffffff81579cf1>] genl_rcv_msg+0x91/0xd0
 [<ffffffff81577ef9>] netlink_rcv_skb+0xa9/0xc0
 [<ffffffff815783f8>] genl_rcv+0x28/0x40
 [<ffffffff8157754d>] netlink_unicast+0xdd/0x190
 [<ffffffff815778ff>] netlink_sendmsg+0x2ff/0x740
 [<ffffffff81574602>] ? netlink_seq_start+0x22/0x40
 [<ffffffff81575935>] ? netlink_recvmsg+0x205/0x390
 [<ffffffff81534229>] sock_sendmsg+0x99/0xd0
 [<ffffffff81534898>] ? sock_recvmsg+0xa8/0xe0
 [<ffffffff81577745>] ? netlink_sendmsg+0x145/0x740
 [<ffffffff8153461c>] ___sys_sendmsg+0x36c/0x380
 [<ffffffff81532e9f>] ? sock_destroy_inode+0x2f/0x40
 [<ffffffff811c1668>] ? destroy_inode+0x38/0x60
 [<ffffffff811bcbcf>] ? __d_free+0x3f/0x60
 [<ffffffff811c592e>] ? mntput_no_expire+0x3e/0x120
 [<ffffffff811c5a36>] ? mntput+0x26/0x40
 [<ffffffff811a9c7c>] ? __fput+0x16c/0x230
 [<ffffffff81535402>] __sys_sendmsg+0x42/0x80
 [<ffffffff81535452>] SyS_sendmsg+0x12/0x20
 [<ffffffff81656e99>] system_call_fastpath+0x16/0x1b
Comment 4 Stanislaw Gruszka 2013-11-04 06:03:27 EST
Josh, please apply above patch. It remove the WARN_ON that is reported and it also should fix related problems. Since those problems are not easily reproducible (happen after 2 weeks of uptime) I prefer just to apply the patch instead of preparing test kernel. If problems will still happens, bug should be reopened.
Comment 5 Josh Boyer 2013-11-04 08:50:19 EST
Added to all branches.  Thanks!
Comment 6 Fedora Update System 2013-11-04 15:16:13 EST
kernel-3.11.7-300.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.11.7-300.fc20
Comment 7 Fedora Update System 2013-11-04 15:18:00 EST
kernel-3.11.7-200.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.11.7-200.fc19
Comment 8 Fedora Update System 2013-11-04 15:19:03 EST
kernel-3.11.7-100.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.11.7-100.fc18
Comment 9 Fedora Update System 2013-11-05 15:02:31 EST
Package kernel-3.11.7-300.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.11.7-300.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20705/kernel-3.11.7-300.fc20
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-11-07 23:39:37 EST
kernel-3.11.7-200.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-11-10 02:54:38 EST
kernel-3.11.7-300.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-11-12 21:13:38 EST
kernel-3.11.7-100.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.