Bug 1025825 - SSSD should warn or show error when offline parameters set with junk values
SSSD should warn or show error when offline parameters set with junk values
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ding-libs (Show other bugs)
7.0
x86_64 Linux
unspecified Severity medium
: rc
: 7.1
Assigned To: Jakub Hrozek
Kaushik Banerjee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 12:56 EDT by Amith
Modified: 2015-04-24 07:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-24 07:24:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amith 2013-11-01 12:56:37 EDT
Description of problem:
This is a known issue, however i couldn't locate a bug on the same. SSSD should show warning message or error message upon service startup, when the pam section of sssd.conf is configured with junk values assigned to offline parameters like given below:

offline_credentials_expiration = o
offline_failed_login_attempts = l
offline_failed_login_delay = !

SSSD starts successfully, which is not expected in this case.

Version-Release number of selected component (if applicable):
sssd-1.9.2-129.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Add the above mentioned offline parameters to pam section of sssd.conf

2. Start sssd service, you will notice that service starts successfully without any warning/error message.

Actual results:
SSSD successfully starts and shows no error.

Expected results:
SSSD should warn or show error message and fail to start.

Additional info:
Comment 2 Jakub Hrozek 2013-11-04 01:16:08 EST
This is a long standing problem that should be fixed in ding-libs. Reassigning. 

I haven't found any open already existing clone (except for #578511 which is closed) so I'm going to keep this one open.
Comment 3 Jakub Hrozek 2013-11-04 01:17:23 EST
Upstream ticket:
https://fedorahosted.org/sssd/ticket/416
Comment 4 RHEL Product and Program Management 2013-11-04 01:20:06 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 7 Martin Kosek 2015-04-24 07:24:37 EDT
Thank you taking your time and submitting this request for Red Hat Enterprise Linux. Unfortunately, this bug was not given a priority and was deferred both in the upstream project and in Red Hat Enterprise Linux.

Given that we are unable to fulfill this request in following Red Hat Enterprise Linux releases, I am closing the Bugzilla as DEFERRED. To request that Red Hat re-considers the decision, please re-open the Bugzilla via appropriate support channels and provide additional business and/or technical details about its importance to you.

Note that you can still track this request or even contribute patches in the referred upstream Trac ticket.

Note You need to log in before you can comment on or make changes to this bug.