Bug 1025837 - livemedia creator does not clear /tmp/yum.repos.d
livemedia creator does not clear /tmp/yum.repos.d
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
19
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 13:38 EDT by D. Marlin
Modified: 2014-03-27 13:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: lorax-21.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-27 13:17:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D. Marlin 2013-11-01 13:38:51 EDT
Description of problem:

livemedia-creator does not clear old data in /tmp/yum.repos.d before a run, so old repo definitions from previous runs may be unintentionally included.


Version-Release number of selected component (if applicable):

lorax-19.5-1


How reproducible:


consistently

Steps to Reproduce:
1.  Run livemedia-creator with a specific repo (url=xxx)
2.  Run livemedia-creator again with a different repo (url=yyy)
3.

Actual results:

Incorrect packages may be pulled in due to the use of the wrong (old) repo.


Expected results:

Only repos specified in the kickstart file would be used to install packages.


Additional info:

Note You need to log in before you can comment on or make changes to this bug.