Bug 102585 - Evolution opens links in gedit, despite preferred app settings
Evolution opens links in gedit, despite preferred app settings
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: libgnome (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-18 08:52 EDT by Thomas J. Baker
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-19 04:01:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2003-08-18 08:52:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030701 Galeon/1.3.7

Description of problem:
When clicking on a link in a mail message, evolution recently started opening
gedit instead of my preferred web browser, galeon. It is set correctly in the
Preferred Applications preference. I'm not sure this if this is an evolution
problem or a gtkhtml problem. I don't think the evo rpm has changed recently but
this link problem has appeared in the last week or so.

Version-Release number of selected component (if applicable):
evolution-1.4.4-3, gtkhtml3-3.0.8-2

How reproducible:
Always

Steps to Reproduce:
1.Open an email with an embedded link
2. Click link
3.
    

Actual Results:  gedit opens with the web page of the link displayed.

Expected Results:  galeon (or whatever my preferred application is) is opened
with the link displayed.

Additional info:
Comment 1 Randy Glenn 2003-08-21 22:01:40 EDT
Similar problem here - links in Evolution and Straw (which uses gtkhtml) will
not open, no matter what the preferences are set to.

gtkhtml-1.1.9-4
gtkhtml3-3.0.8-2
gtkhtml2-2.3.5-1
gnome-python2-gtkhtml2-1.99.16-1
evolution-1.4.4-3

Evolution gives this error at console: gnome_url_show: The default action does
not support this protocol. Straw's error is worded similarly.
Comment 2 Michael Lee Yohe 2003-08-22 15:03:46 EDT
I am seeing a variation of this problem.  When I click on the link - sometimes
nothing happens.  Sometimes Galeon pops up...

Can't seem to reproduce the problem, however.
Comment 3 Jeremy Katz 2003-08-26 12:25:25 EDT
This is due to changes in gnome_url_show().  Alex was looking at this
Comment 4 Thomas J. Baker 2003-09-05 09:00:02 EDT
This seems to be fixed on at least two of my four rawhide systems. But on one,
it still opens gedit. Any clues as to where I could look to fix it? Everything
is set correctly in the Preferred Applications Applet, and I realize that that
applet recently changed. I've quit and restarted evo but it still uses gedit.
Comment 5 Thomas J. Baker 2003-09-18 14:11:30 EDT
This works everywhere for me now.
Comment 6 Alexander Larsson 2003-09-19 04:01:23 EDT
I'm closing this then

Note You need to log in before you can comment on or make changes to this bug.