Bug 102588 - Formbuilder dies when entering '&' in a field
Formbuilder dies when entering '&' in a field
Status: CLOSED RAWHIDE
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks: 100952
  Show dependency treegraph
 
Reported: 2003-08-18 08:59 EDT by Daniel Berrange
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-09 18:06:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2003-08-18 08:59:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
The formbuilder throws an exception if the user enters '&' in one of the  fields
for adding a widget to a form. THis is because the formbuilder stores these
attributes as an XML string, but doesn't take care to escape reserved characters.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a Form item
2. Add a Text field
3. Enter 'Hello & World' in the 'label' field.
    

Actual Results:  Exception is thrown

Expected Results:  No exception is thrown

Additional info:

Fixed in p4 34870
Comment 1 Archit Shah 2003-11-18 16:44:31 EST
fixed in 5.2.x (38128), dev (38129), and 6.0.x (38130)

Note You need to log in before you can comment on or make changes to this bug.