Bug 1025887 - Neutronclient should not obsolete quantumclient [NEEDINFO]
Neutronclient should not obsolete quantumclient
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-neutronclient (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: beta
: 4.0
Assigned To: Jakub Ruzicka
Roey Dekel
:
Depends On: 1025509
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 16:13 EDT by Jakub Ruzicka
Modified: 2016-04-26 12:20 EDT (History)
9 users (show)

See Also:
Fixed In Version: python-neutronclient-2.3.1-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1025509
Environment:
Last Closed: 2013-12-19 19:33:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mlopes: needinfo? (jruzicka)


Attachments (Terms of Use)

  None (edit)
Description Jakub Ruzicka 2013-11-01 16:13:46 EDT
+++ This bug was initially created as a clone of Bug #1025509 +++

Description of problem:

The python-neutronclient package should not conflict with or obsolete the python-quantumclient package. Staging upgrades requires nova to continue using quantumclient until it is upgraded to havana, but a system with both quantum/neutron and nova installed will not be able to do this because of the current conflict.
Comment 3 Scott Lewis 2013-11-19 11:55:00 EST
Auto adding >= MODIFIED bugs to beta
Comment 4 Roey Dekel 2013-11-21 02:18:43 EST
I want to clarify the issue, in order for me to reproduce it.
Is the bug happening when upgrading from quantum to neutron, hence, I should try upgrading and see if the upgrade let the environment countinue working at the background, or is it just a conflict when both of the packages are installed in the same setup?
Comment 5 Jakub Ruzicka 2013-11-21 13:01:36 EST
I think confirming both packages can be installed at same time is sufficient.
Comment 6 Roey Dekel 2013-12-02 02:12:26 EST
Verified on Grizzly -> Havana:

Version-Release number of selected component (if applicable):
=============================================================
Grizzly Puddle: 2013-11-14.2
Havana Puddle: 2013-11-26.3

Results:
========
quantum packages before upgrade:
python-quantumclient-2.2.1-2.el6ost.noarch
python-quantum-2013.1.4-3.el6ost.noarch
openstack-quantum-openvswitch-2013.1.4-3.el6ost.noarch
openstack-quantum-2013.1.4-3.el6ost.noarch

upgrade: `yum upgrade *quantum*`

quantum/neutron packages after upgrade:
python-quantumclient-2.2.1-2.el6ost.noarch
python-neutronclient-2.3.1-2.el6ost.noarch
openstack-neutron-openvswitch-2013.2-10.el6ost.noarch
python-neutron-2013.2-10.el6ost.noarch
openstack-neutron-2013.2-10.el6ost.noarch
Comment 9 errata-xmlrpc 2013-12-19 19:33:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.