Bug 1025914 - disabling crl/curl in Makefile.inc still requires you to have all curl dependencies
disabling crl/curl in Makefile.inc still requires you to have all curl depend...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreswan (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 19:26 EDT by maswank
Modified: 2014-09-19 06:16 EDT (History)
3 users (show)

See Also:
Fixed In Version: libreswan-3.10-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-01 08:41:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description maswank 2013-11-01 19:26:25 EDT
Description of problem:
Changing http crl to false in Makefile.inc still requires you to have all curl/curl-devel and dependencies.


Version-Release number of selected component (if applicable):
rhel 6.4/libreswan 3.6


How reproducible:
Everytime

Steps to Reproduce:
1.Download Rhel 6.4 and have no yum repos defined.
2.Download Libreswan 3.6 and Edit Makefile.inc, Change http crls to false
3.Compile. Notice you have to go into dependency hell to download all curl dependecies

Actual results:


Expected results:
Setting crl\http to false should not require dependencies and install normally and build/install normally.


Additional info:
Similar bug to having dnssec dependencies even though dnssec is false in Makefile.inc
Comment 1 maswank 2013-11-01 19:32:38 EDT
Specifically USE_LIBCURL?=false


Same issue happening with XAUTH. Requires all pam modules and dependencies if set to false. Should log this as separate bug. 

ifeq ($(OSDEP),linux)
USE_XAUTHPAM?=true
endif
Comment 3 Paul Wouters 2013-11-02 01:42:33 EDT
(note this should really be rhel7 libreswan component)

I just did this on fedora 19. I ensured libcurl-devel was not installed. I changed Makefile.inc to have:

USE_LIBCURL?=false

Then ran "make programs" which worked without problems.

The USE_XAUTHPAM= option is autodetected by OS, however, we do set it using
the "?=" make syntax, meaning a command line or env variable should override this without issue.

So, I'm not able to reproduce this? Can you give a more verbose test method? Did you use rpmbuild to build the package? It overrides all the Makefile.inc variables in the spec file.
Comment 4 Paul Wouters 2013-11-02 19:02:48 EDT
the curl-devel issue confirmed.
Comment 5 Eric Paris 2013-12-04 11:42:54 EST
I have moved this bug from RHEL to Fedora rawhide.  If this is a problem it is a problem with the version of libreswan in Fedora, not with anything supplied in RHEL6.
Comment 6 Fedora Update System 2014-07-11 11:53:29 EDT
libreswan-3.9-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreswan-3.9-1.fc20
Comment 7 Fedora Update System 2014-07-11 11:54:34 EDT
libreswan-3.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libreswan-3.9-1.fc19
Comment 8 Fedora Update System 2014-07-11 22:21:51 EDT
Package libreswan-3.9-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreswan-3.9-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8272/libreswan-3.9-1.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2014-09-09 15:17:51 EDT
libreswan-3.10-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreswan-3.10-3.fc20
Comment 10 Fedora Update System 2014-09-09 15:30:20 EDT
libreswan-3.10-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libreswan-3.10-3.fc19
Comment 11 Fedora Update System 2014-09-19 06:12:33 EDT
libreswan-3.10-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2014-09-19 06:16:38 EDT
libreswan-3.10-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.