This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1025915 - dlna upnp browsing not working in totem
dlna upnp browsing not working in totem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: grilo (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 19:38 EDT by Sergio Pascual
Modified: 2016-09-21 12:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-17 19:25:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 722943 None None None Never

  None (edit)
Description Sergio Pascual 2013-11-01 19:38:57 EDT
Description of problem:
Dlna shares are shown in the sidebar. But when I double click in one of the them, I get an error popup window; "Browse Error Action Failed". And I can't browse the share

Version: totem-3.10.1-1.fc20.x86_64 grilo-0.2.7-1.fc20.x86_64 grilo-plugins-0.2.9-2.fc20.x86_64

In F19, I can browse and play videos from the share: totem-3.8.2-1.fc19.x86_64 grilo-0.2.6-1.fc19.x86_64 grilo-plugins-0.2.8-2.fc19.x86_64
Comment 1 Sergio Pascual 2013-11-01 19:45:26 EDT
I have just discovered grilo-test-ui-0.2...

With this test program, I can browse the share. So it works with grilo-test-ui-0.2 and it doesn't with totem
Comment 2 Martin Edlman 2013-12-30 09:16:43 EST
I can confirm the same behaviour. Totem worked with uPnP in FC19, not working in FC20. Grilo browser (grilo-test-ui-0.2) can browse the uPnP fine.
Comment 3 Sergio Pascual 2014-02-22 11:17:24 EST
For those who have similar problems, grilo-0.2.9-1.fc21.x86_64.rpm from Rawhide fixes this bug
Comment 4 Sergio Pascual 2014-03-17 19:25:24 EDT
This has been fixed in 

https://admin.fedoraproject.org/updates/FEDORA-2014-2982/grilo-0.2.9-2.fc20
Comment 5 Pavel 2014-04-01 23:03:15 EDT
I'm afraid it's not over. Browsing DLNA shares worked just fine in fc18, works only for videos in fc19, and saying that it works in fc20 with latest updates is a big stretch. Discovering DLNA servers - no problem, but expanding and browsing music shares with mp3s - doesn't work - they just don't expand. With fc20 sometimes is works, sometimes it doesn't. Since it didn't work at all infc20, I had to downgrade to fc19.

On fc19:
Server - minidlna 1.0.22 with a large collection of mp3/mp4/mkv files.
Client - totem-3.8.2-1.fc19, grilo-0.2.6-1.fc19, grilo-plugins-0.2.8-2.fc19
Result: music shares are not expanded to see any mp3 files, video folders (mkv) are consistently expanded. With Samsung BR player both music and video folders are consistently expanded and playable.

On fc20:
Server - minidlna 1.0.22 with a large collection of mp3/mp4/mkv files.
Client - totem, grilo-0.2.9-2.fc20 - result - consistent non-expansion of music (mp3) folders and occasional expansion of video (mkv) folders. With Samsung BR player both music and video folders are consistently expanded and playable.
Comment 6 Pavel 2014-04-01 23:14:30 EDT
FYI, tested also with latest minidlna shipped with fc20 and rygel. Same behavior as described above.

Note You need to log in before you can comment on or make changes to this bug.