Bug 102593 - KSpread: Program Crashes when trying to load file from Floppy
KSpread: Program Crashes when trying to load file from Floppy
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: koffice (Show other bugs)
beta1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-18 10:23 EDT by Justin Churchey
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 07:04:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Churchey 2003-08-18 10:23:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
When trying to open up a file from a floppy disk in KSpread, the program crashes
and KDE sends me the following backtrace:

0x002c143e in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#0  0x002c143e in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00178e7c in waitpid () from /lib/tls/libpthread.so.0
#2  0x00818ba2 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#3  <signal handler called>
#4  0x00dcef3c in memcpy () from /lib/tls/libc.so.6
#5  0x074488b5 in KLaola::readBigBlockDepot() ()
   from /usr/lib/kde3/libolefilter.so
#6  0x0744762b in KLaola::KLaola(myFile const&) ()
   from /usr/lib/kde3/libolefilter.so
#7  0x074408b2 in OLEFilter::convert(QCString const&, QCString const&) ()
   from /usr/lib/kde3/libolefilter.so
#8  0x00a66759 in
KoFilterChain::ChainLink::invokeFilter(KoFilterChain::ChainLink const*) () from
/usr/lib/libkofficecore.so.2
#9  0x00a671fd in KoFilterChain::invokeChain() ()
   from /usr/lib/libkofficecore.so.2
#10 0x00a530e4 in KoFilterManager::import(QString const&,
KoFilter::ConversionStatus&) () from /usr/lib/libkofficecore.so.2
#11 0x00a4b3ae in KoDocument::openFile() () from /usr/lib/libkofficecore.so.2
#12 0x00f7e59f in KParts::ReadOnlyPart::openURL(KURL const&) ()
   from /usr/lib/libkparts.so.2
#13 0x00a4aa70 in KoDocument::openURL(KURL const&) ()
   from /usr/lib/libkofficecore.so.2
#14 0x00a5b5a2 in KoMainWindow::openDocumentInternal(KURL const&, KoDocument*)
    () from /usr/lib/libkofficecore.so.2
#15 0x00a5b4f2 in KoMainWindow::openDocument(KoDocument*, KURL const&) ()
   from /usr/lib/libkofficecore.so.2
#16 0x00a61791 in KoApplication::start() () from /usr/lib/libkofficecore.so.2
#17 0x00227580 in main () from /usr/lib/kspread.so
#18 0x0804c7a7 in strcpy ()
#19 0x0804d97b in strcpy ()
#20 0x0804de2b in strcpy ()
#21 0x0804ebda in strcpy ()
#22 0x00d6b678 in __libc_start_main () from /lib/tls/libc.so.6

Version-Release number of selected component (if applicable):
koffice-1.2.1-11

How reproducible:
Always

Steps to Reproduce:
1.Browse floppy with Konqueror
2.Right click on .xls file
3.Choose to Open w/ KSpread
    

Actual Results:  The program brings up a frame and then quickly crashes,
bringing up the KDE Crash Handler and giving out the previously mentioned backtrace.

Expected Results:  KSpread should open the file with no problem.

Additional info:
Comment 1 Ngo Than 2003-08-20 09:39:57 EDT
i cannot reproduce this problem on my machine. which kernel version do you have
running on your machine?

It would be helpfull if you could send me this xls file, which causes this
problem. thanks

does it work for you if you start you kspread with:

  LD_ASSUME_KERNEL=2.4.1 kspread



Comment 2 Justin Churchey 2003-08-20 10:57:15 EDT
It is the SMP kernel that came w/ Beta 1.  I will e-mail the XLS file to you 
since I cannot post that file type here.
Comment 3 Ngo Than 2003-08-28 07:04:44 EDT
the xls file, which you have sent to me, is broken.

Note You need to log in before you can comment on or make changes to this bug.