Bug 1025965 - RFE: Please add gpr directory
RFE: Please add gpr directory
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-gnat-project-common (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Björn Persson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-02 10:35 EDT by Pavel Zhukov
Modified: 2014-06-18 03:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 04:38:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Zhukov 2013-11-02 10:35:54 EDT
Description of problem:
It would be great to have gprdir variable in the directories.gpr file (with IncludeDir and Libdir)
Please add it if possible.
Comment 1 Björn Persson 2013-11-02 12:15:34 EDT
You mean an assignment like this?

   GPRdir := "/usr/share/gpr";

How would you use it? It won't help the GNAT tools find project files, because they need to already know to look in /usr/share/gpr to find directories.gpr.
Comment 2 Björn Persson 2013-11-08 12:28:47 EST
Pavel, please explain in what situation you think this variable would be useful. I will push an update next week, adding Alidir and Archincludedir to accommodate Comfignat 1.2. It's easy to add GPRdir too, but I want to know what you intend to use it for.
Comment 3 Pavel Zhukov 2013-11-18 04:38:01 EST
Bjorn, 

Yep. It's my fault. I thought that for Source_List use Directories.GPRDir & "gnatcoll/sql.lgpr" would be better... Looks like it's wrong way. 

I'm sorry for bugging you.

Note You need to log in before you can comment on or make changes to this bug.