Bug 1026002 - btrfs: error while loading shared libraries: liblzo2.so.2
btrfs: error while loading shared libraries: liblzo2.so.2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: btrfs-progs (Show other bugs)
20
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Josef Bacik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-02 16:07 EDT by Gene Czarcinski
Modified: 2013-11-02 22:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-02 22:04:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2013-11-02 16:07:55 EDT
Description of problem:
This problem is occurring for me in the anaconda runtime system.  This is occurring on ISOs created by pungi/lorax of Fedora 19 with updates, Fedora 20 "Beta, and Rawhide.  All of the problems involve 
   btrfs-progs-0.20.rc1.20130917git194aa4a-1 

If I downgrade to btrfs-progs-0.20.rc1.20130308git704a08c-1 the problem goes away.

For some strange reason, I am NOT having the problem on the "official" ISOs such as 20-Beta-TC6

This concerns me because of the large impact but, on the other hand, the problem does not occur with "offical" ISOs.  I have no idea what the probleem really is except that btrfs is simply dead.

The full error messaage is:

btrfs: error while loading shared libraries: liblzo2.so.2: cannot open shared object file: No such file or directory

I originally reported this against lorax as bugzilla bug 1025290 but lots of testing proved that the problem is btrfs-progs.  I have not yet tried rebuilding btrfs-progs.

I am running a number of BTRFS systems both real and virtual and have no problems with the current version except when running in the anaconda-runtime environment.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Gene Czarcinski 2013-11-02 22:04:35 EDT
Not your problem.  The "new" btrfs-progs package uses/requres liblzo.so.2 (lzo) which Fedora 20's lorax has added to Fedora 20's adaconda's runtime.  But, if you do not build on Fedora 20 because pungi/lorax is flacky on F20 so you do it on F19 and pick up the wrong install and btrfs does not work.

Note You need to log in before you can comment on or make changes to this bug.