Bug 1026071 - scanner device created with wrong permissions
scanner device created with wrong permissions
Status: CLOSED DUPLICATE of bug 1023073
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-03 06:40 EST by Kim Bisgaard
Modified: 2013-12-12 20:56 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-12 20:56:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim Bisgaard 2013-11-03 06:40:41 EST
Description of problem:
Sane does not find my scanner. By changing permission on device file, it does.

Additional info:
# cat /proc/scsi/scsi 
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: WDC WD3000GLFS-0 Rev: 03.0
  Type:   Direct-Access                    ANSI  SCSI revision: 05
Host: scsi4 Channel: 00 Id: 00 Lun: 00
  Vendor: PLEXTOR  Model: CD-R   PX-W1610A Rev: 1.05
  Type:   CD-ROM                           ANSI  SCSI revision: 05
Host: scsi4 Channel: 00 Id: 01 Lun: 00
  Vendor: PLEXTOR  Model: DVDR   PX-708A   Rev: 1.06
  Type:   CD-ROM                           ANSI  SCSI revision: 05
Host: scsi7 Channel: 00 Id: 06 Lun: 00
  Vendor:          Model: Scanner 636A4    Rev: 1.60
  Type:   Scanner                          ANSI  SCSI revision: 02

# tail /var/log/messages
Nov  3 10:15:58 kim kernel: [ 2019.788717] scsi7 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 7.0
Nov  3 10:15:58 kim kernel: [ 2019.788717]         <Adaptec aic7850 SCSI adapter>
Nov  3 10:15:58 kim kernel: [ 2019.788717]         aic7850: Single Channel A, SCSI Id=7, 3/253 SCBs
Nov  3 10:15:58 kim kernel: [ 2019.788717]
Nov  3 10:16:00 kim kernel: [ 2021.366901] (scsi7:A:6:0): refuses synchronous negotiation. Using asynchronous transfers
Nov  3 10:16:00 kim kernel: [ 2021.381303] scsi 7:0:6:0: Scanner                    Scanner 636A4    1.60 PQ: 0 ANSI: 2
Nov  3 10:16:00 kim kernel: [ 2021.381328] scsi target7:0:6: Beginning Domain Validation
Nov  3 10:16:00 kim kernel: [ 2021.419033] scsi target7:0:6: Ending Domain Validation
Nov  3 10:16:00 kim kernel: [ 2021.431632] scsi 7:0:6:0: Attached scsi generic sg1 type 6

# ls -l /dev/sg*
crw-rw----. 1 root disk  21, 0 Nov  3 09:42 /dev/sg0
crw-------. 1 root root  21, 1 Nov  3 10:16 /dev/sg1
crw-rw----+ 1 root cdrom 21, 2 Nov  3 09:42 /dev/sg2
crw-rw----+ 1 root cdrom 21, 3 Nov  3 09:42 /dev/sg3

# cat /sys/dev/char/21\:1/uevent 
MAJOR=21
MINOR=1
DEVNAME=sg1
Comment 1 Lennart Poettering 2013-12-12 20:56:41 EST

*** This bug has been marked as a duplicate of bug 1023073 ***

Note You need to log in before you can comment on or make changes to this bug.