Bug 1026087 - Wrong symlink of default.cfg
Wrong symlink of default.cfg
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clark Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-03 09:58 EST by Christopher Meng
Modified: 2013-12-19 00:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 00:23:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Meng 2013-11-03 09:58:58 EST
Today when I tried to run review, fedora-review failed to run as normal.



11-03 22:56 root         DEBUG    Init output: ERROR: Could not find required config file: /etc/mock/default.cfg
ERROR:   Did you forget to specify the chroot to use with '-r'?
 None
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/FedoraReview/mock.py", line 481, in init
    self._rpm_eval('%{_libdir}')
  File "/usr/lib/python2.7/site-packages/FedoraReview/mock.py", line 254, in _rpm_eval
    return check_output(cmd).decode('utf-8').strip()
  File "/usr/lib/python2.7/subprocess.py", line 575, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
CalledProcessError: Command '['mock', '--no-cleanup-after', '--no-clean', '--resultdir=/home/rpmaker/Desktop/python-blosc/results', '--quiet', '--shell', 'rpm --eval \\"%{_libdir}\\"']' returned non-zero exit status 1
11-03 22:56 root         INFO     Init command returned error code 1


My command line:
fedora-review -rvn python-blosc-1.1-3.fc19.src.rpm 

Then I took a look:

[rpmaker@fab mock]$ ll default.cfg 
lrwxrwxrwx. 1 root root 16 11月  2 08:21 default.cfg -> fedora--i386.cfg

Terminal is flashing the fedora--i386.cfg as it doesn't exist.

[rpmaker@fab mock]$ rpm -qa|grep fedora-review
fedora-review-0.5.0-3.fc21.noarch
Comment 1 Stanislav Ochotnicky 2013-11-04 04:07:49 EST
This is most likely a mock configuration issue on your side, but just in case I am reassigning to mock so that maintainer can double check defaults
Comment 2 Clark Williams 2013-11-04 13:06:16 EST
sounds like something went wrong during the %post section of the mock install. It's supposed to symlink /etc/mock/default.cfg to the host OS config. 

Looks like you're running rawhide?
Comment 3 Christopher Meng 2013-11-04 23:56:27 EST
(In reply to Clark Williams from comment #2)
> sounds like something went wrong during the %post section of the mock
> install. It's supposed to symlink /etc/mock/default.cfg to the host OS
> config. 
> 
> Looks like you're running rawhide?

Yes, that's why I reported this because I haven't changed anything on my machine but suddenly it's broken...

I tried yum reinstall and it still happened so I deleted the symlink and created it again.
Comment 4 Christopher Meng 2013-11-05 05:01:57 EST
I think -34 rev removed scripts for symlinking, and then caused this, -35 seems working.
Comment 5 Christopher Meng 2013-12-19 00:23:08 EST
LGTM.

Note You need to log in before you can comment on or make changes to this bug.