Bug 1026090 - brightness keys won't step up or down
brightness keys won't step up or down
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
20
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 1117780 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-03 10:30 EST by Jeff Bastian
Modified: 2015-06-29 08:47 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-29 08:47:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 710380 None None None Never

  None (edit)
Description Jeff Bastian 2013-11-03 10:30:29 EST
Description of problem:
The brightness keys on my Lenovo T60 do not work with Gnome 3.10 on Fedora 20.  They worked fine with Gnome 3.8 on Fedora 19.  Dragging the slider does work, however.

Apparently this is due to a bug calculating the brightness steps with systems where max_brightness is less than 10.  The T60 has a max of 7:

$ cat /sys/class/backlight/acpi_video0/max_brightness
7

See https://bugzilla.gnome.org/show_bug.cgi?id=710380


Version-Release number of selected component (if applicable):
gnome-settings-daemon-3.10.1-2.fc20.x86_64

How reproducible:
every time

Steps to Reproduce:
1. hit Fn+Home (brightness up) or Fn+End (brightness down) on Lenovo T60

Actual results:
the OSD pops up, but the brightness does not change

Expected results:
brightness goes up/down as requested

Additional info:
Comment 1 Rolle 2013-11-29 16:50:52 EST
The same here with Laptop Fujitsu Lifebook E8420

lspci
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

Fedora 20 beta, kernel 3.11.9
Comment 2 Illtud Daniel 2014-01-15 16:57:05 EST
Me too.

[root@vaio backlight]# lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)

Sony Vaio BZ12XN
Comment 3 Benjamin Gerfelder 2014-01-19 20:57:49 EST
Same issue on Asus Zenbook Prime UX31A and Acer Aspire One 756.
Comment 4 Jeff Bastian 2014-03-31 08:00:11 EDT
I tried rhughes' Gnome 3.12 build for Fedora 20 and the brightness keys work again.

http://copr.fedoraproject.org/coprs/rhughes/f20-gnome-3-12/
Comment 5 Hans de Goede 2014-11-10 04:43:31 EST
*** Bug 1117780 has been marked as a duplicate of this bug. ***
Comment 6 Benjamin Kwiecien 2015-04-26 22:36:44 EDT
This bug affected my system, and I want to note that when I first encountered it, the brightness keys would not work at all, but gnome would catch the keystrokes and show an onscreen-display of the brightness control slider (it just wouldn't move).

After a later update, it seems now that the kernel is catching the keystrokes, because brightness adjustment keys do work now, but it's happening independently of gnome's adjuster (works the same on the virtual console and during boot).

dmesg shows my kernel setting the brightness with thinkpad_acpi. Display is using radeon kernel modesetting.

Ideally gnome would be in sync with keyboard-based adjustment and show the OCD accordingly, like how sound volume adjustment is currently working.
Comment 7 Fedora End Of Life 2015-05-29 05:40:50 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Fedora End Of Life 2015-06-29 08:47:56 EDT
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.