Bug 1026096 - Jerky and Reversing scrolling in Firefox
Jerky and Reversing scrolling in Firefox
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
19
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-03 10:55 EST by Peter Gückel
Modified: 2013-11-08 12:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-08 12:09:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Gückel 2013-11-03 10:55:45 EST
Description of problem:
Both with and without smooth scrolling in Firefox, the scrolling is jerky and sometimes jogs back in the reverse direction, before jerkily scrolling forward. It is frustrating to scroll through a web page in Firefox.

Version-Release number of selected component (if applicable):
25.0-3

How reproducible:
Scroll through a web page longer than the screen height.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Scrolling should be smooth, never jog backward, and be synchronous to the actual command given by the person employing the scroll wheel.

Additional info:
When I disable 'use hardware acceleration when available', then the problem appears to be resolved. I only just tried this a moment ago, so I cannot say with a great deal of certainty.
Comment 1 Peter Gückel 2013-11-03 11:02:08 EST
Further info: I don't know whether my system has hardware acceleration for the scroll wheel or whether it does not have scroll wheel acceleration. The way the option is phrased, "use hardware acceleration if available", suggests that Firefox will determine whether it is available and use it only if it is indeed available. I believe that this option is enabled by default in Fedora, despite the fact that it certainly appears that Firefox does not correctly determine this information, or that the acceleration module is not working.

I have been plagued with this problem since Fedora 19 was released, and never thought to disable scroll wheel hardware acceleration, since I thought that Firefox would figure it out.
Comment 2 Peter Gückel 2013-11-04 10:49:50 EST
Since I have been trying to determine a setting that works, I have determined, so far, that no matter what is turned on or off, scrolling is jerky and bumpy.

I am presently on google+ with both autoscrolling and hardware acceleration off and the pages jump and jerk and freeze. This is how Firefox works on web pages these days.
Comment 3 Peter Gückel 2013-11-04 11:07:16 EST
Well, that's the pits :-{(

I got so frustrated, that I switched to my wired mouse and keyboard, and the problem is gone! Even with hardware acceleration and smooth scrolling (that was a mistake in Comment 2, I don't use autoscrolling) enabled.

I will test for a while, but I think it's the wireless HIDs that are the problem.
Comment 4 Martin Stransky 2013-11-04 11:17:02 EST
Okay, thanks for the info.
Comment 5 Peter Gückel 2013-11-08 12:09:00 EST
I'm going to close this, since I've been using the wired mouse for days now and the problem has disappeared. It was the wireless keyboard/trackball combo unit.

Note You need to log in before you can comment on or make changes to this bug.