Bug 1026117 - Please ship Fedora's AppStream data separately from gnome-software
Please ship Fedora's AppStream data separately from gnome-software
Status: CLOSED DUPLICATE of bug 1107802
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1026118
  Show dependency treegraph
 
Reported: 2013-11-03 17:36 EST by T.C. Hollingsworth
Modified: 2014-07-08 12:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-08 12:16:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description T.C. Hollingsworth 2013-11-03 17:36:58 EST
It'd be really cool to turn on AppStream in KDE's apper, but right now it would need to Require gnome-software to actually get the XML data, which is...suboptimal to say the least.

I know you all are working on getting it integrated into the rel-eng workflow properly, but in the interim can you please at least ship the data in a subpackage of gnome-software or, preferably, in its own SRPM.  That way apper can require the necessary XML data without dragging in half of GNOME in the process.

Thanks!
Comment 1 Rex Dieter 2013-11-03 21:56:20 EST
In case this is relevant...
http://www.freedesktop.org/wiki/Distributions/Distributions/AppStream/Software/

bug #1026139 is a quick appstream package I whipped up for review.
(Regardless, this library is required to enable support in apper)
Comment 2 Richard Hughes 2013-12-10 05:23:00 EST
So I'm torn about this. I would be trivial for me to splitout a gnome-software-data subpackage, although I'd much rather spend the time on doing the rel-eng integration. I suppose we can always remove the subpackage in the future.
Comment 3 Kevin Kofler 2014-07-08 12:16:29 EDT
We actually have this now.

*** This bug has been marked as a duplicate of bug 1107802 ***

Note You need to log in before you can comment on or make changes to this bug.