This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1026164 - [ja_JP] notation for MB/KB/B is not unified (Admin>Resource Usage)
[ja_JP] notation for MB/KB/B is not unified (Admin>Resource Usage)
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
4.0
Unspecified Unspecified
low Severity low
: async
: 4.0
Assigned To: Yuko Katabami
Ami Jeain
: Translation, Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 00:29 EST by Mie Yamamoto
Modified: 2013-12-16 09:56 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 09:56:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Notation of MB-KB-B (64.48 KB, image/png)
2013-11-04 00:29 EST, Mie Yamamoto
no flags Details

  None (edit)
Description Mie Yamamoto 2013-11-04 00:29:12 EST
Created attachment 818893 [details]
Notation of MB-KB-B

Description of problem:
if the usage is xx MB or KB shows in MB or KB.
However, if the usage is 0, it shows 0 BYTE (バイト)


Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1.Click on Admin-System Panel-Resources Usage tab from the left side panel
2.In all the subtab, those MB/KB/BYTE is displayed
3.

Actual results:
MB/KB/0バイト


Expected results:

MB/KB/B

Additional info:
Comment 2 Yuko Katabami 2013-11-10 15:58:29 EST
Reported to the upstream ja-JP user group on 8 Nov and is currently under discussion.
Comment 3 Julie Pichon 2013-11-14 10:10:21 EST
In my opinion it would make more sense if they were all localised - e.g. in French Mb is Mo and this would need to be updated. However here, these values are actually already localised and translated. They come from the Django Japanese translations and choosing to translate it this way appears to be a choice from the Django Japanese community, see:

https://github.com/django/django/blob/master/django/conf/locale/ja/LC_MESSAGES/django.po#L793

If we want this to change, we should see about submitting a patch to the Django project to make the translations more consistent. Coincidentally, Django also uses Transifex to manage their translations:

https://docs.djangoproject.com/en/1.6/internals/contributing/localizing/#translations
https://www.transifex.com/projects/p/django-core/
Comment 4 Yuko Katabami 2013-12-11 17:51:41 EST
The final decision made by the upstream user group was to remove the unit for the value between 0-1023.

This fix has been merged into the upstream Havana Stable Update.
Moving the status to POST.

@Julie
With regard to your comment on Django, would you like me to ask Motoki-san whether we should make it consistent?
Comment 5 Julie Pichon 2013-12-12 04:46:07 EST
Yuko,

Thank you for the update. Changing the target to async to reflect the translation update decision.

I think it would be useful to discuss the Django translation status, though this should now be tracked separately.
Comment 6 Yuko Katabami 2013-12-12 04:52:58 EST
(In reply to Julie Pichon from comment #5)
> Yuko,
> 
> Thank you for the update. Changing the target to async to reflect the
> translation update decision.
> 
> I think it would be useful to discuss the Django translation status, though
> this should now be tracked separately.

Hi Julie,

Thank you for your comment.
I shall discuss it and then file a separate bug, as you suggested.
Comment 7 Yuko Katabami 2013-12-15 17:46:01 EST
Hi Julie,

I found that the table which contains these values (and the units) in statistics is removed from Resource Usage tab.

Motoki-san explained to me that the table will be removed for the Stable Update (2013.2.1) because it contained inaccurate information and misleading.

When this change is applied, the bug to verify will not exist.

Do you think I can close this bug now?
Comment 8 Yuko Katabami 2013-12-16 03:30:19 EST
@Julie
Additional note:

- According to Motoki-san, the inconsistent notation for these units we reported is not caused by filters provided by Django, thus we do not need to bring this to the upstream discussion.

- We fixed this in translation (but the page containing these values were removed as reported above).

- Motoki-san filed this bug: https://bugs.launchpad.net/horizon/+bug/1261279
Comment 9 Julie Pichon 2013-12-16 09:56:04 EST
Thank you for the additional information and links! Since the bug is not valid anymore (cf. comment 7 - this was also backported to RHEL-OSP as part of bug 1038723) I will close it now.

Note You need to log in before you can comment on or make changes to this bug.