Bug 102617 - kudzu segfaults
kudzu segfaults
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kudzu (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 102615 102671 102699 114676 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-18 15:11 EDT by Chris Ricker
Modified: 2014-03-16 22:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.1.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-18 17:22:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f /usr/sbin/kudzu -t 30 output (117.05 KB, text/plain)
2003-08-18 15:12 EDT, Chris Ricker
no flags Details
ifcfg-eth0 (53 bytes, text/plain)
2003-08-18 15:17 EDT, Chris Ricker
no flags Details
ifcfg-eth1 (52 bytes, text/plain)
2003-08-18 15:18 EDT, Chris Ricker
no flags Details
ifcfg-lo (269 bytes, text/plain)
2003-08-18 15:18 EDT, Chris Ricker
no flags Details
lspci -v -v output (6.96 KB, text/plain)
2003-08-18 15:41 EDT, Chris Ricker
no flags Details
strace with malloc check (27.48 KB, text/plain)
2003-08-18 16:56 EDT, Chris Ricker
no flags Details
malloc_check strace (27.48 KB, application/octet-stream)
2003-08-18 17:02 EDT, Chris Ricker
no flags Details

  None (edit)
Description Chris Ricker 2003-08-18 15:11:06 EDT
I yum'ed a fresh severn install to today's rawhide. Now, kudzu segfaults:

# /etc/init.d/kudzu start
Checking for new hardware/etc/init.d/kudzu: line 97:  1845 Segmentation fault   
   /usr/sbin/kudzu $KUDZU_ARGS -t 30
                                                           [FAILED]
Updating /etc/fstab                                        [  OK  ]
# strace -f /usr/sbin/kudzu -t 30

This is with:

kernel-2.4.21-20.1.2024.2.1.nptl
kudzu-1.1.16-1.1
Comment 1 Bill Nottingham 2003-08-18 15:12:46 EDT
Got that strace?
Comment 2 Chris Ricker 2003-08-18 15:12:46 EDT
Created attachment 93724 [details]
strace -f /usr/sbin/kudzu -t 30 output
Comment 3 Bill Nottingham 2003-08-18 15:13:37 EDT
Please attach /etc/sysconfig/network-scripts/ifcfg-*.
Comment 4 Chris Ricker 2003-08-18 15:17:51 EDT
Created attachment 93725 [details]
ifcfg-eth0
Comment 5 Chris Ricker 2003-08-18 15:18:09 EDT
Created attachment 93726 [details]
ifcfg-eth1
Comment 6 Chris Ricker 2003-08-18 15:18:27 EDT
Created attachment 93727 [details]
ifcfg-lo
Comment 7 Chris Ricker 2003-08-18 15:20:50 EDT
Only eth0, eth1, and lo config files. eth1 is disabled in the bios (onboard VIA
rhine), but w/o ifcfg-eth1 present, it still segfaults

Only thing unusual is that NOZEROCONF is in all the configs, and lo is a file
rather than a symlink (symlink stuff is a PITA whenever you upgrade if you've
added NOZEROCONF, BTW)
Comment 8 Chris Ricker 2003-08-18 15:40:04 EDT
Hmm, not related to ifcfg-eth1. I re-enabled that in the bios, and it still
segfaults
Comment 9 Chris Ricker 2003-08-18 15:40:53 EDT
The basic hardware is:

[cricker@yoshimi cricker]$ /sbin/lspci 
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
00:0b.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
00:0d.0 Unknown mass storage controller: Promise Technology, Inc. 20265 (rev 02)
00:0e.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233 PCI to ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE (rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. USB (rev 1b)
00:11.3 USB Controller: VIA Technologies, Inc. USB (rev 1b)
00:11.4 USB Controller: VIA Technologies, Inc. USB (rev 1b)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 70)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 If [Radeon
9000] (rev 01)
01:00.1 Display controller: ATI Technologies Inc Radeon R250 [Radeon 9000]
(Secondary) (rev 01)
[cricker@yoshimi cricker]$ 
Comment 10 Chris Ricker 2003-08-18 15:41:37 EDT
Created attachment 93728 [details]
lspci -v -v output
Comment 11 Bill Nottingham 2003-08-18 15:42:54 EDT
*** Bug 102615 has been marked as a duplicate of this bug. ***
Comment 12 Bill Nottingham 2003-08-18 15:50:07 EDT
hardware is probably irrelevant.

Can you run MALLOC_CHECK_=2 strace kudzu ..? Is the strace appreciably
different? (It's running OK here with those files.)
Comment 13 Bill Nottingham 2003-08-18 15:50:55 EDT
Alternatively, a gdb backtrace would be nice; I'll chuck the debuginfo package
on people.redhat.com/notting/kudzu/
Comment 14 Chris Ricker 2003-08-18 16:24:55 EDT
Hmm, I did the MALLOC_CHECK_ strace (what's that doing exactly? what its name
suggests?). That's a 31 meg strace though, so I'll have to post it on a web
server somewhere ;-)

I haven't so far managed to get gdb to backtrace. It's not dumping core, and if
I just run gdb kudzu, and then try to run it, I get the error:

Starting program: /usr/sbin/kudzu
30: No such file or directory.

Program exited with code 01.
Comment 15 Chris Ricker 2003-08-18 16:26:24 EDT
Hmm, FWIW, redhat-config-packages segfaults as well, and it looks like the same
cause. Its strace goes:

<snip>
4444  open("/etc/sysconfig/network-scripts/ifcfg-eth0", O_RDONLY) = 4
4444  fstat64(4, {st_mode=S_IFREG|0644, st_size=53, ...}) = 0
4444  read(4, "DEVICE=eth0\nBOOTPROTO=dhcp\nONBOO"..., 53) = 53
4444  close(4)                          = 0
4444  open("/etc/sysconfig/network-scripts/ifcfg-eth1", O_RDONLY) = 4
4444  fstat64(4, {st_mode=S_IFREG|0644, st_size=52, ...}) = 0
4444  read(4, "DEVICE=eth1\nBOOTPROTO=dhcp\nONBOO"..., 52) = 52
4444  close(4)                          = 0
4444  open("/etc/sysconfig/network-scripts/ifcfg-lo", O_RDONLY) = 4
4444  fstat64(4, {st_mode=S_IFREG|0644, st_size=269, ...}) = 0
4444  read(4, "DEVICE=lo\nIPADDR=127.0.0.1\nNETMA"..., 269) = 269
4444  close(4)                          = 0
4444  --- SIGSEGV (Segmentation fault) @ 0 (0) ---
Comment 16 Bill Nottingham 2003-08-18 16:28:22 EDT
gdb kudzu
set args -t 30

You can't pass args to the program on the gdb commandline.

Yes, it's the same segfault. I've made a tweak in CVS so it will (hopefully)
stop crashing things like r-c-p and r-c-xfree86, but I still need to track down
the bug.
Comment 17 Chris Ricker 2003-08-18 16:35:54 EDT
Ah, thanks. Now I've got a backtrace:

Program received signal SIGSEGV, Segmentation fault.
matchNetDevices (devlist=0x95120b8) at kudzu.c:1119
1119                    tmpdev = netdevs->next;
(gdb) bt
#0  matchNetDevices (devlist=0x95120b8) at kudzu.c:1119
#1  0x0805214a in probeDevices (probeClass=CLASS_UNSPEC, probeBus=BUS_DDC, 
    probeFlags=1) at kudzu.c:702
#2  0x0804ac14 in Xconfig (dev=0x9524420) at hwconf.c:123
#3  0x0804d4f2 in configure (dev=0x9524420) at hwconf.c:902
#4  0x0804f197 in configMenu (oldDevs=0x95230a0, newDevs=0x9524420, runFirst=0)
    at hwconf.c:1750
#5  0x0804ff55 in main (argc=-268374161, argv=0xf000ef6f) at hwconf.c:1956
(gdb) quit

On the screen, it was asking if I wanted to configure my newly detected video
card (ATI Radeon 9K series)
Comment 18 Chris Ricker 2003-08-18 16:56:52 EDT
Created attachment 93731 [details]
strace with malloc check

If it will be useful, I've also attached the strace done with MALLOC_CHECK_=2.
This is only 28k bzip2'ed, so it should be small enough for bugzilla. If not,
and you need it, let me know and I'll put it on a web server somewhere.
Comment 19 Chris Ricker 2003-08-18 17:02:36 EDT
Created attachment 93732 [details]
malloc_check strace

Oops, attached as text instead of binary. Fixed.
Comment 20 Bill Nottingham 2003-08-18 17:22:53 EDT
Fixed in 1.1.17-1. Blarg. Change the 'do {} while' loop to 'while {}'.
Comment 21 Bill Nottingham 2003-08-19 15:38:07 EDT
*** Bug 102671 has been marked as a duplicate of this bug. ***
Comment 22 Bill Nottingham 2003-08-19 22:28:29 EDT
*** Bug 102699 has been marked as a duplicate of this bug. ***
Comment 23 Harald Hoyer 2004-02-05 11:33:33 EST
*** Bug 114676 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.