Bug 1026212 - gnome-keyring-pkcs11.desktop OnlyShowIn=GNOME;Unity;MATE;
gnome-keyring-pkcs11.desktop OnlyShowIn=GNOME;Unity;MATE;
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mate-keyring (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 03:29 EST by Jean-Claude
Modified: 2013-11-04 05:23 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 05:23:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-Claude 2013-11-04 03:29:30 EST
Description of problem:

/usr/bin/gnome-keyring-daemon --start --components=pkcs11 and
/usr/bin/mate-keyring-daemon --start --components=pkcs11
are launched when an user use Mate as desktop.


Version-Release number of selected component (if applicable):
3.8.2-1.fc19

How reproducible:
grep OnlyShowIn /etc/xdg/autostart/gnome-keyring-pkcs11.desktop

Actual results:
OnlyShowIn=GNOME;Unity;MATE;


Expected results:
OnlyShowIn=GNOME;Unity;


Additional info:
Comment 1 Stef Walter 2013-11-04 05:04:00 EST
gnome-keyring project was asked by the Mate guys to include this line:

commit dff0a6edd2c02602b24476296855b4f63f99379f
Author: raveit65 <chat-to-me@raveit.de>
Date:   Thu Aug 9 11:24:31 2012 +0200

    Add MATE Desktop to desktop files
    
     * So that gnome-keyring starts up on the MATE desktop.
    
    https://bugzilla.gnome.org/show_bug.cgi?id=681482
Comment 2 Wolfgang Ulbrich 2013-11-04 05:23:51 EST
For f20 we are switching to gnome-keyring and mate-keyring is obsolete, you can test this currently in rawhide.
I'm waiting of the end of the beta freeze to push ready builds packages in f20.
Using gnome-keyring is a general goal of MATE desktop.
For f19 i don't want to the switch because i'm not shure about the consequences in a release cycle and i don't wanna break user experience.

But some applications ie. networkmanager needs gnome-keyring for wifi password.
Networkmanager is complied against gnome-keyring.
Same for parts of evolution.
So removing MATE from OnlyShowIn is a bad idea.

Note You need to log in before you can comment on or make changes to this bug.