Bug 1026222 - Should not accept configure SNMP without provide password
Should not accept configure SNMP without provide password
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: 6.5
Assigned To: Ryan Barry
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 03:50 EST by wanghui
Modified: 2014-01-21 14:36 EST (History)
15 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-9.el6
Doc Type: Bug Fix
Doc Text:
Users were able to configure SNMP without having to enter a password. Previously when users selected 'enable snmp' without using a password, it would run 'snmp transaction' and enable 'snmp service'. Now if the user selects 'enable snmp' without using a password, the system prompts "Unable to configure SNMP without a password!"
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:36:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wanghui 2013-11-04 03:50:43 EST
Description of problem:
It should be better to not allow configure SNMP without provide password.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20131031.1
ovirt-node-3.0.1-7.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clean install rhev-hypervisor6-6.5-20131031.1.
2. Enable SNMP without provide a password.

Actual results:
1. After step2, it can configure SNMP successfully.

Expected results:
1. It should be better to not allow configure SNMP without provide password.

Additional info:
No such issue in rhevh6.4, so it is a regression bug.
Comment 4 Cheryn Tan 2014-01-08 00:36:30 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 6 wanghui 2014-01-13 21:42:56 EST
Bug re-verify

Test version:
rhevh-6.5-20140110.1.iso
ovirt-node-3.0.1-16.el6_5.noarch

Test step:
1. Clean install rhev-h.
2. Enable SNMP without provide a password.

Test result:
1. After step2, it will give a prompt info as follows.
SNMP Error
Unable to configure SNMP without a password!

So the bug is fixed in rhevh-6.5-20140110.1.iso.
Comment 8 errata-xmlrpc 2014-01-21 14:36:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.