Bug 1026330 - the VM should be in image_locked state when performing offline snapshot operation
the VM should be in image_locked state when performing offline snapshot opera...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Liron Aravot
Pavel Stehlik
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 07:50 EST by David Jaša
Modified: 2016-02-10 14:13 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 07:35:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-11-04 07:50:17 EST
Description of problem:
When the VM is performing a snapshot operation and nothing else can be done, the VM should be in image_locked state

Version-Release number of selected component (if applicable):
is20.2 / rhevm-backend-3.3.0-0.30.beta1.el6ev.noarch

How reproducible:
always

Steps to Reproduce:
1. delete (create, preview, commit) a snapshot whev VM is down
2.
3.

Actual results:
VM status is down during snapshot operation

Expected results:
VM is in image_locked status

Additional info:
Comment 1 Liron Aravot 2013-11-07 06:46:52 EST
Allon,
the removal of the lock of the vm during snapshot is since this patch (old one):
http://gerrit.ovirt.org/#/c/2314/

possibly the intention was that you could do other vm related operations while the snapshot is being taken. like  updating the vm configuration.

As this issue is very old, i think that regardless this could be postponed to 3.4 (as changing it might add some instabiility) and then we could decide on what is the behaviour that we want here.
Comment 2 Allon Mureinik 2013-11-07 07:35:12 EST
On second thought, the initial description of the bug is  incorrect - if a VM is in image locked it cannot be RUN.

Note You need to log in before you can comment on or make changes to this bug.