Bug 1026353 - Improve "Following artifacts were built but are not being installed" error message
Improve "Following artifacts were built but are not being installed" error me...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: javapackages-tools (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: FutureFeature, Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 08:45 EST by Severin Gehwolf
Modified: 2014-07-16 08:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: 4.1.0-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-16 08:38:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Severin Gehwolf 2013-11-04 08:45:12 EST
On a local build of thermostat I see this:

    Traceback (most recent call last):
      File "/usr/lib/rpm/maven.req", line 123, in <module>
        builder = TagBuilder ()
      File "/usr/lib/rpm/maven.req", line 63, in __init__
        self.print_mvn_requires(path)
      File "/usr/lib/rpm/maven.req", line 101, in print_mvn_requires
        raise Exception(skipped_msg)
    Exception: Following artifacts were built but are not being installed however other artifacts require them. Either package these artifacts or do not build them. To package call %mvn_package in %prep:
    %mvn_package com.redhat.thermostat:thermostat-common-test:::0.15.0 <package_name>
     
    Following artifacts were built but are not being installed however other artifacts require them. Either package these artifacts or do not build them. To package call %mvn_package in %prep:
    %mvn_package com.redhat.thermostat:thermostat-common-test:::0.15.0 <package_name>
    close failed in file object destructor:
    sys.excepthook is missing
    lost sys.stderr
    Could not execute local: Non zero exit

thermostat-common-test is a test-only dep (should be <scope>test</scope> only). Apparently there is a thermostat bug in a module which has common-test not scoped as test. Long story short, it would be faster if the error message would include gId:artifactId of the depending modules requiring module X which has been configured via %mvn_package X __noinstall
Comment 1 Michael Simacek 2014-01-02 07:04:54 EST
I'm afraid this can not be solved in the requires generator, because it sees only the depmap. And the depmap contains list of dependencies for whole project, but there's no information about which module produced which dependency.
Comment 2 Stanislav Ochotnicky 2014-03-13 08:48:22 EDT
I'm changing the scope of this to simplify stuff. Let's provide generic steps to debug/figure out solution for this issue and why it's happening.
Comment 3 Michael Simacek 2014-03-14 11:57:42 EDT
Requires generator now tries to find installed POMs and find which artifact requires the skipped/unknown artifact and print its coordinates. It should be available in upstream commit 67b450b
Comment 4 Fedora Admin XMLRPC Client 2014-04-24 08:47:12 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Mikolaj Izdebski 2014-07-16 08:38:23 EDT
I believe that this feature is included in javapackages-tools-4.1.0-2,
which is available in Fedora 21, so I am closing this bug now.

The build which includes the feature can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=543061

Note You need to log in before you can comment on or make changes to this bug.