Bug 102642 - PPP authentication problem (not receive accept and fail)
PPP authentication problem (not receive accept and fail)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Thomas Woerner
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-19 06:51 EDT by Domingo Bolado
Modified: 2015-01-07 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-17 05:44:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Domingo Bolado 2003-08-19 06:51:14 EDT
Description of problem:
A user with Red Hat 7.1 Kernel 2.4.2-2 has an nternet connection with 2 ppp 
authentication, 1º PPP is the RAS MAX-TNT and 2º PPP Is a LNP 3Com PPTP Tunnel-
Server.

The authentiation fail, because the password-accept does not work.

It works with MAX-TNT TAOS 9.0.3 but it is impossible to connect when the MAX-
TNT TAOS is 10.0.2

The user traces are:

May 28 07:49:52 portaredes pppd[761]: pppd 2.4.0 started by root, uid 0
May 28 07:49:52 portaredes pppd[761]: using channel 2
May 28 07:49:52 portaredes pppd[761]: Using interface ppp0
May 28 07:49:52 portaredes pppd[761]: Connect: ppp0 <--> /dev/ttyS0
May 28 07:49:52 portaredes pppd[761]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> 
<magic 0x209a4b07> <pcomp> <accomp>]
May 28 07:49:53 portaredes pppd[761]: rcvd [LCP ConfReq id=0x1 <mru 1524> 
<asyncmap 0xa0000> <auth chap MD5> <pcomp> <accomp> <mrru 1524> <endpoint 
[local:6e.75.72.69.61.2d.4d.50.50]> < 1b 04 02 02>]
May 28 07:49:53 portaredes pppd[761]: sent [LCP ConfRej id=0x1 <mrru 1524> < 1b 
04 02 02>]
May 28 07:49:53 portaredes pppd[761]: rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> 
<magic 0x209a4b07> <pcomp> <accomp>]
May 28 07:49:53 portaredes pppd[761]: rcvd [LCP ConfReq id=0x2 <mru 1524> 
<asyncmap 0xa0000> <auth chap MD5> <pcomp> <accomp> <endpoint 
[local:6e.75.72.69.61.2d.4d.50.50]>]
May 28 07:49:53 portaredes pppd[761]: sent [LCP ConfNak id=0x2 <auth pap>]
May 28 07:49:53 portaredes pppd[761]: rcvd [LCP ConfReq id=0x3 <mru 1524> 
<asyncmap 0xa0000> <auth pap> <pcomp> <accomp> <endpoint 
[local:6e.75.72.69.61.2d.4d.50.50]>]
May 28 07:49:53 portaredes pppd[761]: sent [LCP ConfAck id=0x3 <mru 1524> 
<asyncmap 0xa0000> <auth pap> <pcomp> <accomp> <endpoint 
[local:6e.75.72.69.61.2d.4d.50.50]>]
May 28 07:49:53 portaredes pppd[761]: sent [PAP AuthReq id=0x1 
user="tcpsi@geservp" password=<hidden>]
May 28 07:49:54 portaredes pppd[761]: rcvd [LCP ConfReq id=0x0]
May 28 07:49:54 portaredes pppd[761]: sent [LCP ConfReq id=0x2 <asyncmap 0x0> 
<magic 0x991d0fd0> <pcomp> <accomp>]
May 28 07:49:54 portaredes pppd[761]: sent [LCP ConfAck id=0x0]
May 28 07:49:54 portaredes pppd[761]: rcvd [LCP code=0xc id=0x38 00 00 00 00 56 
49 3d 33 43 4f 4d 20 53 50 3d 53 57 2f 4e 42 53 49 2d 43 46 2c 31 31 2e 31 2e 
30 ...]
May 28 07:49:54 portaredes pppd[761]: sent [LCP CodeRej id=0x3 0c 38 00 46 00 
00 00 00 56 49 3d 33 43 4f 4d 20 53 50 3d 53 57 2f 4e 42 53 49 2d 43 46 2c 31 
31 ...]
May 28 07:49:54 portaredes pppd[761]: rcvd [LCP ConfReq id=0x38 <mru 1524> 
<auth pap> <magic 0x83d6904> <mrru 4500> <endpoint [MAC:08:00:02:29:e5:7c]>]
May 28 07:49:54 portaredes pppd[761]: sent [LCP ConfRej id=0x38 <mrru 4500>]
May 28 07:49:54 portaredes pppd[761]: rcvd [LCP ConfRej id=0x2 <asyncmap 0x0> 
<pcomp> <accomp>]
May 28 07:49:54 portaredes pppd[761]: sent [LCP ConfReq id=0x4 <magic 
0x991d0fd0>]
May 28 07:49:54 portaredes pppd[761]: rcvd [LCP ConfReq id=0x3b <mru 1524> 
<auth pap> <magic 0x83d6904> <endpoint [MAC:08:00:02:29:e5:7c]>]
May 28 07:49:54 portaredes pppd[761]: sent [LCP ConfAck id=0x3b <mru 1524> 
<auth pap> <magic 0x83d6904> <endpoint [MAC:08:00:02:29:e5:7c]>]
May 28 07:49:54 portaredes pppd[761]: rcvd [LCP ConfAck id=0x4 <magic 
0x991d0fd0>]
May 28 07:49:54 portaredes pppd[761]: sent [PAP AuthReq id=0x2 
user="tcpsi@geservp" password=<hidden>]
May 28 07:49:54 portaredes pppd[761]: rcvd [LCP EchoReq id=0x3d magic=0x83d6904]
May 28 07:49:54 portaredes pppd[761]: sent [LCP EchoRep id=0x3d 
magic=0x991d0fd0]
May 28 07:49:57 portaredes pppd[761]: rcvd [LCP EchoReq id=0x73 magic=0x83d6904]
May 28 07:49:57 portaredes pppd[761]: sent [LCP EchoRep id=0x73 
magic=0x991d0fd0]
May 28 07:49:57 portaredes pppd[761]: sent [PAP AuthReq id=0x3 
user="tcpsi@geservp" password=<hidden>]
May 28 07:50:00 portaredes pppd[761]: sent [PAP AuthReq id=0x4 
user="tcpsi@geservp" password=<hidden>]
May 28 07:50:03 portaredes pppd[761]: sent [PAP AuthReq id=0x5 
user="tcpsi@geservp" password=<hidden>]
May 28 07:50:06 portaredes pppd[761]: sent [PAP AuthReq id=0x6 
user="tcpsi@geservp" password=<hidden>]
May 28 07:50:09 portaredes pppd[761]: sent [PAP AuthReq id=0x7 
user="tcpsi@geservp" password=<hidden>]
May 28 07:50:12 portaredes pppd[761]: sent [PAP AuthReq id=0x8 
user="tcpsi@geservp" password=<hidden>]
May 28 07:50:15 portaredes pppd[761]: sent [PAP AuthReq id=0x9 
user="tcpsi@geservp" password=<hidden>]
May 28 07:50:18 portaredes pppd[761]: sent [PAP AuthReq id=0xa 
user="tcpsi@geservp" password=<hidden>]
May 28 07:50:21 portaredes pppd[761]: sent [PAP AuthReq id=0xb 
user="tcpsi@geservp" password=<hidden>]
May 28 07:50:22 portaredes pppd[761]: Terminating on signal 15.
May 28 07:50:22 portaredes pppd[761]: sent [LCP TermReq id=0x5 "User request"]
May 28 07:50:22 portaredes pppd[761]: rcvd [LCP TermAck id=0x5 "User request"]
May 28 07:50:22 portaredes pppd[761]: Connection terminated.
May 28 07:50:22 portaredes pppd[761]: Exit.

We have confirm than the authenticatión accept is sent by MAX-TNT, but the 
Linux-Red-Hat does not receive the packet, that is:

  [0000]: 7e ff 7d 23 c0 23 7d 22  7d 23 7d 20 7d 36 7d 31    ~.}#.#}" }#} }6}1
  [0010]: 50 61 73 73 77 6f 72 64  20 41 63 63 65 70 74 65    Password  Accepte
  [0020]: 64 24 95 7e                                         
Lucent Technologies say than the different TAOS (version) has not almost 
changed, and they do not understand yet why it happens.


Version-Release number of selected component (if applicable):


How reproducible:

I have the telephone number and login/password to reproduce it.
Please, contactme to tell you.

Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Thomas Woerner 2004-08-17 05:44:20 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.