Bug 1026431 - pcs incorrectly detects RHEL6 variants
pcs incorrectly detects RHEL6 variants
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcs (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Chris Feist
:
: 1073584 (view as bug list)
Depends On:
Blocks: 996235
  Show dependency treegraph
 
Reported: 2013-11-04 10:59 EST by Tuomo Soini
Modified: 2014-10-14 03:21 EDT (History)
15 users (show)

See Also:
Fixed In Version: pcs-0.9.123-9.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:21:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to cater for 3 most popular el6 variants (433 bytes, patch)
2013-11-05 17:54 EST, Trevor Hemsley
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Article) 663283 None None None Never

  None (edit)
Description Tuomo Soini 2013-11-04 10:59:51 EST
Description of problem:

snippets of pcs status output:

Cluster name:

cluster name is not shown here while it is set in cluster.conf

Stack: cman

and stack is cman...

PCSD Status:

There is no PCSD in rhel 6.4 so why print this header when pcsd is not even installed.

Error: no nodes found in corosync.conf

This is printed to stderr - this should be very expected with cman stack where there is no corosync.conf at all.
Comment 1 Tuomo Soini 2013-11-04 11:02:52 EST
PCS version is  0.9.90-1.el6_4
Comment 3 Chris Feist 2013-11-04 14:05:00 EST
Can you post the output you get when you run 'pcs status' and the output you get what you run 'pcs cluster status'.
Comment 4 Tuomo Soini 2013-11-05 14:01:17 EST
# pcs cluster status
Cluster Status:
 Last updated: Tue Nov  5 20:55:37 2013
 Last change: Tue Nov  5 20:07:50 2013 via cibadmin on test1.foobar.fi
 Stack: cman
 Current DC: test1.foobar.fi - partition with quorum
 Version: 1.1.10-1.el6_4.4-368c726
 2 Nodes configured
 4 Resources configured

PCSD Status:
Error: no nodes found in corosync.conf

# pcs status
Cluster name: 
Last updated: Tue Nov  5 20:55:30 2013
Last change: Tue Nov  5 20:07:50 2013 via cibadmin on test1.foobar.fi
Stack: cman
Current DC: test1.foobar.fi - partition with quorum
Version: 1.1.10-1.el6_4.4-368c726
2 Nodes configured
4 Resources configured


Online: [ test1.foobar.fi test2.foobar.fi ]

Full list of resources:

 Resource Group: services
     ClusterIP   (ocf::heartbeat:IPaddr2):      Started test1.foobar.fi 
     ldirectord  (lsb:ldirectord):              Started test1.foobar.fi 
 Clone Set: cl-Connectivity [Connectivity]
     Started: [ test1.foobar.fi test2.foobar.fi ]


PCSD Status:
Error: no nodes found in corosync.conf
Comment 5 Tuomo Soini 2013-11-05 14:02:38 EST
everything else is output to stdout but Error: line is stderr.
Comment 6 Chris Feist 2013-11-05 14:49:31 EST
Can you post the output of this command: 'cat /etc/issue'
Comment 7 Tuomo Soini 2013-11-05 16:18:57 EST
You could just ask if this is real rhel or not - it's not - but the problems I described are rhel specific with unmodified software.

ldirctord is our own package.
Comment 8 Tuomo Soini 2013-11-05 16:43:18 EST
ah - I understand - is_rhel6() doesn't work with any rhel clones.

I'll patch to suppot our linux variant. I inform which problems are left behind when os is correctly detected - and I'll inform Centos folks about need for patching.
Comment 9 Trevor Hemsley 2013-11-05 17:54:44 EST
Created attachment 820054 [details]
Proposed patch to cater for 3 most popular el6 variants

One liner patch to work on RHEL6, CentOS 6 and SL6
Comment 10 Chris Feist 2013-11-08 01:17:22 EST
Yes, just wanted to see if that was the issue.

Thanks for that patch, I'll be applying that patch upstream ASAP.

There is also one other issue (that is fixed upstream) which causes the pcsd checks to happen when running 'pcs cluster status' ('pcs status' is fine).

Those messages should be harmless (so you can ignore them).  However, there are a few other situations where is_rhel6 does things differently, so if you're running CentOS or Scientific Linux you'll want to apply that patch on your installs.
Comment 12 Chris Feist 2014-01-13 18:14:15 EST
Note: the patch to fix this issue is here:

https://github.com/feist/pcs/commit/eed5198ea20cbad4be100990a6cca8a101296358
Comment 14 Fabio Massimo Di Nitto 2014-03-27 08:20:27 EDT
*** Bug 1073584 has been marked as a duplicate of this bug. ***
Comment 15 Russ Anderson 2014-05-30 12:32:08 EDT
Status check.  This BZ is marked POST but no indication that the fix is in.
Is this problem fixed?  Or what needs to be done to fix it?
Thanks,
Comment 16 Chris Feist 2014-06-11 17:43:09 EDT
This fix has been committed upstream, but is not yet released in RHEL.
Comment 17 Chris Feist 2014-06-11 17:44:46 EDT
Updated summary to reflect that this bug is for fixing issues with pcs detecting RHEL 6 variants.  pcsd should be working upstream with RHEL 6 systems so 'pcs cluster status' should be printing out this information.
Comment 18 Chris Feist 2014-06-23 10:42:49 EDT
This fix is in the latest pcs build, I'll find an easy way to test this.
Comment 28 Chris Feist 2014-09-03 16:18:45 EDT
Before Fix:


[root@bid-06 pcs]# rpm -q pcs
pcs-0.9.123-6.el6.x86_64
[root@bid-06 pcs]# echo "Red Hat Enterprise Linux Client release 6.5 (Santiago)" > /etc/system-release
[root@bid-06 pcs]# python -c'import utils; print utils.is_rhel6()'
False


After Fix:

[root@bid-05 pcs]# rpm -q pcs
pcs-0.9.123-9.el6.x86_64
[root@bid-05 pcs]# echo "Red Hat Enterprise Linux Client release 6.5 (Santiago)" > /etc/system-release
[root@bid-05 pcs]# python -c'import utils; print utils.is_rhel6()'
True
[root@bid-05 pcs]# echo "Red Hat Enterprise Linux ComputeNode release 6.6 Beta (Santiago)" > /etc/system-release
[root@bid-05 pcs]# python -c'import utils; print utils.is_rhel6()'
True
[root@bid-05 pcs]# echo "Red Hat Enterprise Linux Workstation release 6.6 Beta (Santiago)" > /etc/system-release
[root@bid-05 pcs]# python -c'import utils; print utils.is_rhel6()'
True
[root@bid-05 pcs]# echo "Red Hat Enterprise Linux Server release 7.0 (Maipo)" > /etc/system-release
[root@bid-05 pcs]# python -c'import utils; print utils.is_rhel6()'
False
Comment 31 errata-xmlrpc 2014-10-14 03:21:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1526.html

Note You need to log in before you can comment on or make changes to this bug.