Bug 1026455 - R is not multilib clean
R is not multilib clean
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: R (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 12:07 EST by Jaroslav Škarvada
Modified: 2013-11-11 14:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 14:37:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2013-11-04 12:07:06 EST
Description of problem:
R is not multilib clean, spotted while resolving bug 831392

Version-Release number of selected component (if applicable):
R-3.0.1-4.fc20

How reproducible:
Always

Steps to Reproduce:
1. On x86_64: yum install R-core R-core.i686

Actual results:
Transaction check error:
  file /usr/bin/R conflicts between attempted installs of R-core-3.0.1-4.fc20.i686 and R-core-3.0.1-4.fc20.x86_64
  file /usr/share/doc/R/CAPABILITIES conflicts between attempted installs of R-core-3.0.1-4.fc20.i686 and R-core-3.0.1-4.fc20.x86_64
  file /usr/share/doc/R/NEWS.rds conflicts between attempted installs of R-core-3.0.1-4.fc20.i686 and R-core-3.0.1-4.fc20.x86_64
  file /usr/share/doc/R/html/packages.html conflicts between attempted installs of R-core-3.0.1-4.fc20.i686 and R-core-3.0.1-4.fc20.x86_64
  file /usr/share/doc/R/manual/R-FAQ.pdf conflicts between attempted installs of R-core-3.0.1-4.fc20.i686 and R-core-3.0.1-4.fc20.x86_64
  file /usr/share/doc/R/manual/R-admin.pdf conflicts between attempted installs of R-core-3.0.1-4.fc20.i686 and R-core-3.0.1-4.fc20.x86_64
  file /usr/share/doc/R/manual/R-data.pdf conflicts between attempted installs of R-core-3.0.1-4.fc20.i686 and R-core-3.0.1-4.fc20.x86_64
  file /usr/share/doc/R/manual/R-exts.pdf conflicts between attempted installs of R-core-3.0.1-4.fc20.i686 and R-core-3.0.1-4.fc20.x86_64
  file /usr/share/doc/R/manual/R-intro.pdf conflicts between attempted installs of R-core-3.0.1-4.fc20.i686 and R-core-3.0.1-4.fc20.x86_64
  file /usr/share/doc/R/manual/R-ints.pdf conflicts between attempted installs of R-core-3.0.1-4.fc20.i686 and R-core-3.0.1-4.fc20.x86_64
  file /usr/share/doc/R/manual/R-lang.pdf conflicts between attempted installs of R-core-3.0.1-4.fc20.i686 and R-core-3.0.1-4.fc20.x86_64
  file /usr/share/doc/R/manual/fullrefman.pdf conflicts between attempted installs of R-core-3.0.1-4.fc20.i686 and R-core-3.0.1-4.fc20.x86_64
  file /usr/share/man/man1/R.1.gz conflicts between attempted installs of R-core-3.0.1-4.fc20.i686 and R-core-3.0.1-4.fc20.x86_64

Expected results:
No error

Additional info:
Comment 1 Tom "spot" Callaway 2013-11-11 14:37:52 EST
R is not intended to be multilib clean as it is currently.

The docfile conflicts can be fixed, but /usr/bin/R... that is a generated file (original is src/scripts/R.sh.in), and it inserts a value for R_HOME_DIR that is architecture specific (contains %{_libdir})... changing that to be multilib clean would require changes at the upstream level. If that is something you really want, you should open a ticket with upstream R (preferably with a patch to make src/scripts/R.sh.in multilib compatible).

Closing CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.