Bug 1026536 - [Doc Bug Fix] Incomplete httpd configuration documentation JBoss EAP 6 Administration and Configuration Guide Chapter 16.3.2
[Doc Bug Fix] Incomplete httpd configuration documentation JBoss EAP 6 Admini...
Status: CLOSED DUPLICATE of bug 1200379
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.1
Unspecified Linux
unspecified Severity high
: ---
: EAP 6.4.0
Assigned To: eap-docs
Russell Dickenson
: Documentation, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 17:33 EST by Jan Snelders
Modified: 2015-03-10 09:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.12 Build Name: 19233, Administration and Configuration Guide-6.1-1 Build Date: 05-09-2013 10:36:48 Topic ID: 5728-498505 [Specified]
Last Closed: 2015-03-10 09:04:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Snelders 2013-11-04 17:33:16 EST
Title: Install the Apache HTTPD included with JBoss EAP 6
Chapter 16.3.2

Describe the issue:
1) The described "sudo su apache" doesn seem to work if the user is created as described; with a shell "/sbin/nologin".
2) There seems no point in ending commands with "2> /dev/null || :" as for "/usr/sbin/groupadd -g 91 -r apache 2> /dev/null || :".
It hides useful feedback/responses to the user.
3) It's not described how httpd should be configured to run as a service.

Suggestions for improvement:
1) Having no shell for a system user seems correct. Please describe a way to start httpd under the user apache.
2) Skip tailing commands with "2> /dev/null || :" or otherwise describe why this is needed.
3) Please provide a description (and a script) how httpd can be configure to run as a service (chkconfig/service?)

Additional information:
Comment 2 Michal Karm Babacek 2015-03-10 09:04:24 EDT
I do not agree with Jan Snelders. The suggested configuration is wrong in this context.  Please, follow BZ 1200379 and act accordingly.

*** This bug has been marked as a duplicate of bug 1200379 ***
Comment 3 Michal Karm Babacek 2015-03-10 09:12:58 EDT
 - Regarding user and group Appache -- see comment 2
 - Regarding Jan's request for service description: This has been included in the docs already, describing both init and systemd control for _RPM_ installed Apache HTTP Server.
 - @Jan: Apache is started as root and then it throws root permissions away and it continues as user apache. You don't start httpd directly from apache user's shell. If you desire to do so, simply use: runuser -l apache -c "/your/way/to/start/httpd...".

Please, comment on BZ 1200379 if you have additional questions.

Note You need to log in before you can comment on or make changes to this bug.