Bug 1026601 - shift-y not producing uppercase Y
shift-y not producing uppercase Y
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-11-04 22:29 EST by Joel
Modified: 2014-02-21 13:33 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-02-21 13:33:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
anaconda logs (231.12 KB, application/x-compressed-tar)
2013-11-05 17:30 EST, Joel
no flags Details

  None (edit)
Description Joel 2013-11-04 22:29:54 EST
Description of problem:

on FC20 Beta RC2, when installing, the shift-y keystroke on the en-us keyboard did not produce an uppercase "Y".  Fortunately shiftlock y did produce a "Y".

This was noticed when typing in the username.  However, switching to console, also prevented typing a "Y" with shift-y.

Once installed, shift-y worked fine.

Version-Release number of selected component (if applicable):

FC20 Beta RC2
Comment 1 David Shea 2013-11-05 09:31:18 EST
How did you set your keyboard layout (boot command line, welcome screen, keyboard configuration scren...)? Is this a live CD? Can you include the log files from /tmp?
Comment 2 Joel 2013-11-05 12:59:31 EST
This was a usb image of the Fedora-20-Beta-x86_64-DVD.iso made with libusb-creator.

Where are the /tmp files?  Are these on the installed system?  If so am not seeing them.

Keyboard layout was set from the installer screen that is displayed at the start of installation.

I'll try to reproduce.
Comment 3 David Shea 2013-11-05 14:25:30 EST
The log files are copied into /var/log/anaconda in the installed system.

Did anything unusual appear in the keyboard layout preview (the keyboard icon in the keyboard layout screen)? Did you set anything in the layout switching options?
Comment 4 Joel 2013-11-05 17:30:06 EST
Created attachment 820053 [details]
anaconda logs

I tried to reproduce on the same Dell Latitude E6510 laptop but the problem didn't re-occur.

Attached please find anaconda logs.
Comment 5 Joel 2013-11-05 17:34:14 EST
I don't remember anything unusual appearing in the keyboard layout preview.  I don't remember setting anything odd.  I just went thru normally.  

The only trick was the system I was installing on has its file system LUKS encrypted so anaconda tried to tell me there was no space for the install until I drilled in and unlocked the luks partition.  I doubt that is relevant.

Since as noted above, I was unable to reproduce, I suspect we'll have to take this as anecdotal unless the logs show something or others report it.

Comment 6 David Shea 2014-02-21 13:33:54 EST
Closing since there's no reproducer.

Note You need to log in before you can comment on or make changes to this bug.