Bug 1026630 - When run UEFI-RHEL certification - kdump(local) test with 16GB DIMMx8 ,OS (swap partition) is easy to damage and cannot enter to graphic mode [NEEDINFO]
When run UEFI-RHEL certification - kdump(local) test with 16GB DIMMx8 ,OS (sw...
Status: NEW
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification-hardware (Show other bugs)
1.0
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: brose
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 00:56 EST by matthew
Modified: 2017-04-18 22:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
brose: needinfo? (Matthew.Lin)


Attachments (Terms of Use)

  None (edit)
Description matthew 2013-11-05 00:56:31 EST
Current Behavior
==============================
When run RHEL certification - kdump(local) test with 16GB memory to run UEFI-RHEL6U4-64 under BIOS 4A05, OS (swap partition) is easy to damage. When swap partition damage, system cannot enter to graphic mode, it only can used text mode. 

Memory model: 
(Hynix) Memory,H5TQ4G43AFR,DDR3,14900 (1866MHz),16GB,Register,13,by 4,2 rank, *8 
HDD model: (WD) HDD,SAS2,4TB,SAS,7.2 Krpm,3.5, (WD4001FYYG-79SL3W0), Qty:3
OS partition:
/boot/efi: 20000MB
/boot: 20000MB
/swap: 128000MB
/: over 3TB
v7 version: v7-1.6.4-22.el6.noarch

Expected Behavior
==============================
No matter use any memory to run RHEL cert test, system should not occur any error during test.
Comment 2 RHEL Product and Program Management 2013-11-08 08:56:02 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 matthew 2013-11-12 20:44:12 EST
How could I offer the request to Redhat?
Comment 4 Dave Young 2013-11-13 02:47:08 EST
Hi, matthew

I just want to know how can we reproduce this problem?
What's the machine model?
What's the meaning of swap partition damage, is it means hard disk broken? Are you using hibernate to disk? I'm confused about it.

Thanks
Dave
Comment 5 matthew 2013-11-14 01:12:56 EST
1. What's the machine model?
 > It's Romely platfrom.

2. What's the meaning of swap partition damage, is it means hard disk broken? Are you using hibernate to disk?
 > When systme run kdump(local) test during Redhat certification, system will reboot. After system reboot and enter to OS, it will response swap partition is broken and it needs to be restore. Waiting for swap partition restore finish, system will enter to text read only mode and kdump (local) test item cannot finish test.

Note1: I try to change another HDD(same model) to retry this function, it still get the same result.

Note2: I try to install OS and create partition "/boot/efi" "/boot" and "/" to disk1 and create partition "swap" to disk2 then re-run this test item, it still get the same issue.
Comment 6 Baoquan He 2013-11-15 01:25:36 EST
Hi Matthew,

I may not understand the steps you took. you mean in 1st kernel you were doing Redhat cretification, during this time you wanted to have a kdump test. So you triggered a crash, kdump began working. It would try to shutdown and start 2nd kernel, namely kdump kernel. In kdump kernel, during system startup, error message was shown that swap partition is broken, and need be restored. Then it restore swap, then go to a shell. But vmcore is not dumped correctly. 

Am I right about above steps you are encountering?

Baoquan
Thanks a lot
Comment 7 matthew 2013-11-19 01:55:38 EST
Hi Baoquan

Yes, here are more detail information.

1. In Redhat 6.4-64 OS, start run Redhat certification cert-kdump(local) test.
2. During system running kdump(local), system will auto occur kernel-panic and it will reboot later.
3. When system enter to OS loading bar, system will display swap partition is crash, try to restore this partition(under text read only mode). When the partition resotre to 100 percent, OS will display log in screen.
Comment 10 matthew 2013-12-03 02:29:04 EST
Hi Baoquan

When can we get more detail information about this issue?
Comment 11 Rob Landry 2013-12-04 14:18:30 EST
(In reply to matthew from comment #10)
> Hi Baoquan
> 
> When can we get more detail information about this issue?

Hi Matthew,

We probably 1st need to the separate kdump from the cert suite to see if we can narrow down where the problem exists.

To do this, I think it's probably easiest to start by triggering a kdump directly from a cleanly booted box and then we can see if your issue reproduces. 

What the test does is configure kdump to dump to a local disk.  Next it restarts the kdump service to ensure the correct initrds are created. Then it sets the reboot timeout to 1 (via /proc/sys/kernel/panic) before finally initializing a crash (via /proc/sys/kernel/sysrq).  This should then cause the kdump kernel to start, write it's logs and reboot the system.

Can you attempt the above on your box which reproduces this issue?

If this shows the issue, we'll be on an OS/kdump debugging path, if this does not show the issue we'll need to start on a test suite debugging path.
Comment 12 matthew 2013-12-08 21:55:12 EST
We are trying to follow your information to dump the file as your request.
Comment 14 brose 2017-04-18 22:29:35 EDT
Hello.  Are you still experiencing this issue with the latest released versions of redhat-certification-backend, redhat-certification, and redhat-certification-hardware packages?

Thanks

Note You need to log in before you can comment on or make changes to this bug.