Bug 1026786 - JBAS015960 warnings during JON start up - invalid classpath entries in deployment
JBAS015960 warnings during JON start up - invalid classpath entries in deploy...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ER03
: JON 3.3.0
Assigned To: Jay Shaughnessy
Filip Brychta
:
: 1078494 1078497 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 07:41 EST by Lukas Krejci
Modified: 2014-12-11 08:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-11 08:59:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Krejci 2013-11-05 07:41:32 EST
Description of problem:
When the JON server starts up, it logs a number of JBAS015960 warnings complaining about invalid classpath entries for a number of various libraries.

Not sure if these are really valid, because otherwise the server seems to function normally, but seeing 39 of such warnings (some of them duplicated) in the logs is somewhat disconcerting.

Version-Release number of selected component (if applicable):
JON 3.2.0.ER4

How reproducible:
alwyas

Steps to Reproduce:
1. start up ER4
Comment 6 Jay Shaughnessy 2014-09-05 09:32:37 EDT
The fix is not as simple as suggested in the (hidden) comment above. Because it's out of our control, these are 3rd party libs and EAP generated messages.

Master commit ab38128e3d4d5b1e38005bc108783b36f9ce2c9f
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Fri Sep 5 09:27:54 2014 -0400

    Add logger subsystem filtering to omit the error codes we don't want to
    Filtering out the "invalid class-path" as well as a few other annoying
    warnings.
    - added installer support to set the filter in the standalone-full.xml.


release/jon3.3.x commit b71dc7007c3a5aff4b13022c2e7d16c8a8d521e5
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Fri Sep 5 09:27:54 2014 -0400

    (cherry picked from commit ab38128e3d4d5b1e38005bc108783b36f9ce2c9f)
    Signed-off-by: Jay Shaughnessy <jshaughn@redhat.com>
Comment 7 Jay Shaughnessy 2014-09-05 17:52:06 EDT
*** Bug 1078497 has been marked as a duplicate of this bug. ***
Comment 8 Simeon Pinder 2014-09-16 22:49:05 EDT
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=385149
Comment 9 Filip Brychta 2014-09-18 08:28:06 EDT
verified on
Version :	
3.3.0.ER03
Build Number :	
4aefe39:44e33a4
Comment 10 John Mazzitelli 2014-09-18 10:21:24 EDT
*** Bug 1078494 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.