Bug 1026795 - Packstack fails if installing Nova is disabled
Packstack fails if installing Nova is disabled
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
urgent Severity urgent
: rc
: 4.0
Assigned To: Ivan Chavero
Nir Magnezi
: Regression, TestBlocker
Depends On: 1024564
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 07:58 EST by Martina Kollarova
Modified: 2016-04-26 13:55 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1024564
Environment:
Last Closed: 2013-12-19 19:34:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 52266 None None None Never

  None (edit)
Comment 4 Ivan Chavero 2013-11-14 12:44:12 EST
I'll try to get patch approved so it can make it to the beta
Comment 5 Alvaro Lopez Ortega 2013-12-05 09:55:57 EST
https://review.openstack.org/#/c/52266/ has been merged
Comment 9 Nir Magnezi 2013-12-17 02:24:35 EST
Verified NVR: openstack-packstack-2013.2.1-0.19.dev935.el6ost.noarch

Installed Keystone and Swift, without nova.

packstack --os-swift-install=y --os-swift-storage-zones=1 --os-swift-storage-fstype=ext4 --os-swift-storage=10.x.y.z --os-nova-install=n --os-client-install=y --keystone-host=10.x.y.z --os-horizon-install=n --os-cinder-install=n --install-hosts=10.x.y.z --os-swift-storage-replicas=3 --os-swift-proxy=10.x.y.z --os-glance-install=n --os-neutron-install=n

Result:
=======
Installation ended successfully.

# keystone service-list
+----------------------------------+------------+--------------+--------------------------------+
|                id                |    name    |     type     |          description           |
+----------------------------------+------------+--------------+--------------------------------+
| bf9ae7b1d62446548fa72fab149dbf68 | ceilometer |   metering   |   Openstack Metering Service   |
| 1dafc6a1618e4d6f8d351188f4444f55 |  keystone  |   identity   |   OpenStack Identity Service   |
| ea0cf75891544d77b56408a3f67debb9 |   swift    | object-store | Openstack Object-Store Service |
| 151f300725904b119fc99f581bb04623 |  swift_s3  |      s3      |      Openstack S3 Service      |
+----------------------------------+------------+--------------+--------------------------------+
Comment 11 errata-xmlrpc 2013-12-19 19:34:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.