Bug 1026819 - vlock seems not working on RHEL-7
vlock seems not working on RHEL-7
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kbd (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Vitezslav Crhonek
Tomas Dolezal
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 08:47 EST by Patrik Kis
Modified: 2014-06-18 03:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: kbd-1.15.5-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:09:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrik Kis 2013-11-05 08:47:08 EST
Description of problem:
When locking console in a virtual machine the vlock seems get to endless loop and print only the following message:
The pts/1 is now locked by pkis.
Authentication failure.
It is not possible to enter password at all and it continues until it is killed from another terminal.
It was tested on virtual machine only, but it is expected to work.

Version-Release number of selected component (if applicable):
kbd-1.15.5-6.el7

How reproducible:
always

Steps to Reproduce:
[pkis@rhel7 ~ ]$ vlock 

The pts/1 is now locked by pkis.
Authentication failure.


The pts/1 is now locked by pkis.
Authentication failure.

....%<...........................

From other terminal:
[root@rhel7 ~ ]# killall -9 vlock

Actual results:
It is not possible to unlock.

Expected results:
[pkis@rhel6 ~]$ vlock
 *** This tty is not a VC (virtual console). ***
 *** It may not be securely locked. ***

This TTY is now locked.
Please enter the password to unlock.
pkis's Password: 
[pkis@rhel6 ~]$
Comment 4 Nalin Dahyabhai 2013-11-12 14:00:06 EST
This fix appears to be incomplete - while the missing configuration file has been re-added, vlock doesn't appear to be calling pam_setcred() after successfully verifying the user's identity as the old version did (see also bug #913311).
Comment 5 Tomas Dolezal 2013-11-18 08:12:31 EST
VERIFIED on kbd-1.15.5-7.el7.x86_64
tested on tty and ssh with success on both
Comment 6 Nalin Dahyabhai 2013-11-18 09:23:12 EST
The problem I mentioned in comment #4 appears to be causing bug #1029374.  Does that fix belong here, or in a new bug?
Comment 7 Tomas Dolezal 2013-11-19 06:35:55 EST
Hi Nalin,
problem described in comment 1 is fixed, this blocker bug has to be verified by the end of this week.

I was unable to reproduce your bug 913311. Please try to reproduce on kbd-1.15.5-7.el7.x86_64 and then be sure to clone the bug to RHEL7 product. If I had succeeded, I would have done that.
Comment 8 Nalin Dahyabhai 2013-11-19 10:39:27 EST
Alright, then, cloning the other bug.  Thanks!
Comment 9 Ludek Smid 2014-06-13 07:09:53 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.