This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1026837 - openlmi-networking does not support sfcb
openlmi-networking does not support sfcb
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openlmi-providers (Show other bugs)
rawhide
All Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Radek Novacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 09:06 EST by Klaus Kämpf
Modified: 2016-11-30 19:32 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 04:07:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaus Kämpf 2013-11-05 09:06:57 EST
Description of problem:
openlmi-networking does not support sfcb since 90_LMI_Networking_Profile.mof creates instances of PG_ProviderProfileCapabilities which is not available with sfcb.

Version-Release number of selected component (if applicable):
0.2.1

How reproducible:
Install openlmi-networking on a system with only sfcb installed

Steps to Reproduce:
1. run sfcbrepos -f
2.
3.

Actual results:
error in /tmp/sfcbinst.mof line 1 near CIM_System: class definition for PG_ProviderProfileCapabilities not found
class definition for PG_ProviderProfileCapabilities not found


Expected results:
No error

Additional info:
Comment 1 Radek Novacek 2013-11-06 08:14:11 EST
It works fine for me. The '90_LMI_Networking_Profile.mof' file that contains the profile registration should be applied only to pegasus.

Could you run `openlmi-mof-register list` command and attach the result here? Note that you need openlmi-providers 0.4.1, but that's requirement of openlmi-networking 0.2.1 anyways.
Comment 2 Klaus Kämpf 2013-11-07 04:07:11 EST
Oh, my bad. I didn't spot the %post changes in the spec file. Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.