Bug 1026882 - rsdl are missing request payload details
rsdl are missing request payload details
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Shubhendu Tripathi
Dustin Tsang
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 10:12 EST by Dustin Tsang
Modified: 2015-07-13 00:39 EDT (History)
9 users (show)

See Also:
Fixed In Version: cb10
Doc Type: Bug Fix
Doc Text:
Previously, the payload details were not displayed in the RSDL listing. Now, with this update, the URL patterns in the RSDL listing are corrected and the payload details are displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:59:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rsdl from cb6 (45.59 KB, application/xml)
2013-11-13 08:31 EST, Dustin Tsang
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21355 None None None Never

  None (edit)
Description Dustin Tsang 2013-11-05 10:12:33 EST
Description of problem:

In rhsc-cb6 the rsdl does not contain the details of what the payload or headers expected by the server. 

For example, in rhsc-cb6 the rsdl description for adding a volume is 

---------rsdl excerpt------------
<link href="/api/clusters/{cluster:id}/glustervolumes" rel="add">
<request>
<http_method>POST</http_method>
<body>
<type>GlusterVolume</type>
</body>
</request>
<response>
<type>GlusterVolume</type>
</response>
</link>
----------end rsdl excerpt----------



The rsdl description which is correct in the previous version:

------------rsdl exerpt---------------
<link href="/api/clusters/{cluster:id}/glustervolumes" rel="add">
<description>add a new gluster volume to the cluster</description>
<request>
<http_method>POST</http_method>
<headers>
<header required="true">
<name>Content-Type</name>
<value>application/xml|json</value>
</header>
<header required="false">
<name>Expect</name>
<value>201-created</value>
</header>
<header required="false">
<name>Correlation-Id</name>
<value>any string</value>
</header>
</headers>
<body>
<type>GlusterVolume</type>
<parameters_set>
<description>
add a new gluster volume to the cluster at the specified gluster fs server
</description>
<parameter required="true" type="xs:string">
<name>gluster_volume.name</name>
</parameter>
<parameter required="true" type="xs:string">
<name>gluster_volume.volume_type</name>
</parameter>
<parameter required="true" type="collection">
<name>gluster_volume.bricks.brick</name>
<parameters_set>
<parameter required="true" type="xs:string">
<name>brick.server_id</name>
</parameter>
<parameter required="true" type="xs:string">
<name>brick.brick_dir</name>
</parameter>
</parameters_set>
</parameter>
<parameter required="false" type="collection">
<name>gluster_volume.transport_types</name>
<parameters_set>
<parameter required="false" type="xs:string">
<name>transport_type</name>
</parameter>
</parameters_set>
</parameter>
<parameter required="false" type="xs:unsignedShort">
<name>gluster_volume.replica_count</name>
</parameter>
<parameter required="false" type="xs:unsignedShort">
<name>gluster_volume.stripe_count</name>
</parameter>
<parameter required="false" type="collection">
<name>gluster_volume.options.option</name>
<parameters_set>
<parameter required="false" type="xs:string">
<name>option.name</name>
</parameter>
<parameter required="false" type="xs:string">
<name>option.value</name>
</parameter>
</parameters_set>
</parameter>
</parameters_set>
</body>
</request>
<response>
<type>GlusterVolume</type>
</response>
</link>
-----------end excerpt------------

Version-Release number of selected component (if applicable):
rhsc-cb6

How reproducible:
100%

Steps to Reproduce:
1. go to /api?rsdl


Actual results:
request descriptors contain no payload or header information.

Expected results:
request descriptors should contain information about expected payloads and headers expected.

Additional info:
Comment 2 Shubhendu Tripathi 2013-11-13 00:27:40 EST
Dustin, I am able to see the payload details properly with cb6 build.
Kindly verify once.
Comment 3 Dustin Tsang 2013-11-13 08:31:34 EST
Created attachment 823446 [details]
rsdl from cb6
Comment 4 Shubhendu Tripathi 2013-11-18 23:37:04 EST
The patch 21308 is asked to be abandoned and Ori has posted a patch which would take care of the scenario better.

http://gerrit.ovirt.org/#/c/21355
Comment 5 Shalaka 2014-01-08 01:39:48 EST
Please review the edited DocText and signoff.
Comment 6 Shubhendu Tripathi 2014-01-08 03:33:36 EST
Doc text looks fine
Comment 8 errata-xmlrpc 2014-02-25 02:59:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.