Bug 1026965 - Designer falsely detects midair collision when only one user is working in a process
Designer falsely detects midair collision when only one user is working in a ...
Status: CLOSED DUPLICATE of bug 1111406
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Jeremy Lindop
Sona Mala
:
: 1078105 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 13:04 EST by Pedro Zapata
Modified: 2014-11-19 08:26 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Process modeler incorrectly detects multiple users working on a process. It doesn't prevent the user from working with the process but just displays a message. This error occurs intermittently. Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
BPMS-6.0.0.ER5
Last Closed: 2014-11-19 08:26:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Message (37.08 KB, image/png)
2013-11-05 13:04 EST, Pedro Zapata
no flags Details
How to reproduce vid. (804.09 KB, video/mp4)
2013-11-26 04:52 EST, Marek Baluch
no flags Details

  None (edit)
Description Pedro Zapata 2013-11-05 13:04:55 EST
Created attachment 819929 [details]
Message

Process modeler sometimes incorrectly states that the same user is updating the resource in background when saving new process (see screenshot 1). It doesn't prevent working, just can be annoying.

Create new processes, start working on it, save it. Sometimes will get the message.
Comment 2 Marek Baluch 2013-11-26 04:51:39 EST
Occurs also on BPMS 6.0.0.ER5 but with much greater frequency!

Description of problem:
A collision may be detected on each save. The first save sometimes will succeed but all subsequent saves will exhibit this behaviour.   

Steps to Reproduce:
- Create a new process
- Perform some modifications
- Save the process
- Perform another modification
- Save the process
Comment 3 Marek Baluch 2013-11-26 04:52:02 EST
Created attachment 829123 [details]
How to reproduce vid.
Comment 4 Jan Hrcek 2013-12-04 07:47:47 EST
Similar issue exists for FormModeler: see bug 1038108
Comment 5 Tihomir Surdilovic 2014-02-06 15:27:41 EST
this issue should be fixed already. please re-test
Comment 6 Sona Mala 2014-02-20 09:51:05 EST
I am not able to find commit on github which contains this issue in comment. Also I can reproduce this issue in ER1 6.0.1. The second attempt to save process always invoke midair collision.
Comment 7 Kris Verlaenen 2014-03-20 10:01:48 EDT
*** Bug 1078105 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Lindop 2014-11-19 08:26:03 EST

*** This bug has been marked as a duplicate of bug 1111406 ***

Note You need to log in before you can comment on or make changes to this bug.