Bug 1027014 - [ALL_LANG] Wrong quota name listed on Default Quotas tab
[ALL_LANG] Wrong quota name listed on Default Quotas tab
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
4.0
Unspecified Unspecified
medium Severity unspecified
: z1
: 4.0
Assigned To: Julie Pichon
Lijun Li
: i18n, Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 17:06 EST by Yuko Katabami
Modified: 2016-04-26 09:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.2.1-1.el6ost
Doc Type: Bug Fix
Doc Text:
In OpenStack Dashboard, the string for the injected_file_path_bytes quota was mistakenly set to "Injected File Content Bytes". As a result, in the Defaults quotas tab, "Injected File Content Bytes" would appear twice, but with two different values. This has been fixed so that the list of defaults for quotas is now displayed correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 09:23:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Default Quotas tab - Quotas table (109.16 KB, image/png)
2013-11-05 17:06 EST, Yuko Katabami
no flags Details
Update Default Quotas wiindow (91.02 KB, image/png)
2013-11-05 17:07 EST, Yuko Katabami
no flags Details
Injected File Path Bytes -- fixed (en-US) (95.57 KB, image/png)
2014-01-21 00:51 EST, Yuko Katabami
no flags Details
Injected File Path Bytes -- fixed (ja-JP) (110.28 KB, image/png)
2014-01-21 00:52 EST, Yuko Katabami
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1254049 None None None Never
OpenStack gerrit 58103 None None None Never

  None (edit)
Description Yuko Katabami 2013-11-05 17:06:18 EST
Created attachment 820046 [details]
Default Quotas tab - Quotas table

Description of problem:
In Quotas table, one of the quota name is wrong

Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1. Log in to Dashboard with admin account
2. On the left side panel, click Admin => Defaults 
3. On the main panel, check the quota names listed: There are two "Injected File Content Bytes" with different values (10240 and 255)
4. Click "Update Defaults" button
5. Check the default quotas listed.
"Injected File Content Bytes" has value of 10240
"Injected File Path Bytes" has value of 255

Actual results:
In the Quotas table on the Default Quotas tab, duplicated quota "Injected File Content Bytes" is listed with value of 255


Expected results:
It should be changed to "Injected File Path Bytes"

Additional info:
Screenshots attached
Comment 1 Yuko Katabami 2013-11-05 17:07:22 EST
Created attachment 820048 [details]
Update Default Quotas wiindow
Comment 3 Yuko Katabami 2013-11-05 17:49:01 EST
Confirmed that translation of the string "Injected File Path Bytes" is included in the upstream file.
Comment 4 Julie Pichon 2013-11-12 11:49:04 EST
The error slipped in the English strings when the default quota names were made translatable: https://git.openstack.org/cgit/openstack/horizon/tree/openstack_dashboard/dashboards/admin/defaults/tables.py#n42
Comment 5 Julie Pichon 2013-11-27 05:49:28 EST
Backported submitted upstream, should be part of 2013.2.1.
Comment 7 Yuko Katabami 2014-01-21 00:51:50 EST
Created attachment 852970 [details]
Injected File Path Bytes -- fixed (en-US)
Comment 8 Yuko Katabami 2014-01-21 00:52:29 EST
Created attachment 852971 [details]
Injected File Path Bytes -- fixed (ja-JP)
Comment 9 Yuko Katabami 2014-01-21 00:53:03 EST
Verified on the latest RHOS 4.0.z puddle. Screenshot attached. Moving the status to VERIFIED.
Comment 12 Lon Hohberger 2014-02-04 12:20:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-0046.html

Note You need to log in before you can comment on or make changes to this bug.